Very Slow Client Backup (50 KBit/s)


#1

Hello,

I am using UrBackup a few weeks now and I love it. I am backing up about 10 clients and every client is running with full wire speed (100 or 1000 MBit).

Except ONE client!

This client is backing up with only 50 KBit/s, so a backup of only 80 Megabytes takes hours.

This client is a normal PC, not a notebook. The power management settings are set to maximum performance. I disabled the antivirus (ESET) and the CPU is only running at a few percent load. The UrBackup client threads are running at zero percent CPU load.

The network and the storage could also not be the problem, as I can access the storage with full wire speed (90-110 MB/s) from this client

So it must be something with the UrBackup client application, not the server. As I said, all other clients are working well with great speed.

I also tried to set the thread priority to high instead of background priority, but this didn’t helped, too.

Any help would be greatly appreciated.

Dino


#2

I have this exact same issue with one server!


#3

That means you used eg. “Process Hacker 2” to set the priority of the threads, correct?


#4

You could upload/send me a process monitor trace. Maybe that will tell the cause.


#5

You don’t need Process Hacker or else for this. I did it in the normal windows task manager, right click on the running .exe and then set priority.


#6

That way you are setting the priority of the whole process. Individual threads will still have low IO priority. So you should redo that experiment with Process Hacker 2.


#7

I tried again with Process Hacker and set every process and thread to high priority, but nothing changed.


#8

I have this problem too!
30.03.17 11:06 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 1% finished 386.828 KB/23 MB at 52.728 KBit/s
30.03.17 11:07 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 3% finished 770.828 KB/23 MB at 52.352 KBit/s
30.03.17 11:08 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 4% finished 1.12776 MB/23 MB at 52.352 KBit/s
30.03.17 11:09 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 6% finished 1.50276 MB/23 MB at 52.352 KBit/s

30.03.17 11:34 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 47% finished 10.8764 MB/23 MB at 52.168 KBit/s
30.03.17 11:35 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 48% finished 11.2514 MB/23 MB at 52.352 KBit/s
30.03.17 11:36 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 50% finished 11.6264 MB/23 MB at 52.36 KBit/s
23 MB copied for an hour!

I have already used the advice, I installed the Hacker Process 2 and raised all the priorities to high and it did not help.


#9

Same here:

16.04.17 18:54 DEBUG Loading “.symlink_SqlServerWriter_{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 53% finished 6.81388 MB/12.75 MB at 52.312 KBit/s
16.04.17 18:55 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 56% finished 7.18888 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:56 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 59% finished 7.56388 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:57 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 62% finished 7.93888 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:58 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 65% finished 8.31388 MB/12.75 MB at 52.328 KBit/s
16.04.17 18:59 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}_80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf”. 68% finished 8.69026 MB/12.75 MB at 52.512 KBit/s


#10

If you change settings in advanced tab and set every local transfer modes same as internet transfer mode, it will be fast then…

I’m not sure about that, but when i change filesystem type to btrfs for backupstore, speed is avesome:

17.04.17 13:15 INFO Transferred 27.6498 MB - Average speed: 13.5473 MBit/s


#11

I am having this problem since upgrading to latest Windows Server and Client versions with only 1 client.

It’s going to take days on this client to do a backup as the speed is showing/maxing out at about 1.5mbits.
I have run tests, and with this client doesn’t have problem transferring files to/from the server using Windows/shares.

I’ve been spending hours trying to figure out what’s the cause and haven’t come up with anything.

One thing I notice: if I filter process monitor on UrBackupClientBackend.exe, seems like there is a pattern (on larger files) of 4 TCPSend operations followed by 1 TCP Retransmit…


#12

If you can, send me that (filtered) process monitor log.


#13

Here is another one:

I will come back to this thread when this backup is finished :wink:


#14

Sorry to not have replied -
I did find out that I did actually have a bad network cable! So, nothing wrong with Urbackup.


#15

It looks like your client may be on Pause. If you right-click the UrBackup tray icon, do you see the word Pause or Continue there? (third word from the bottom)


#16

Anyone ever found something regarding this issue ? trying to do internet backup of a server in our office to another location and hitting the same problem.

I know on my side it’s no bad network cable… servers are VMs


#17

Thank you for the tip about it being paused. That is exactly what my problem was. Now I’m confused as to how it became paused. Oh well. Thanks again!


#18

I’ve been in the same situation. You reboot the client service and it’s fast.


#19

Is there a solution for this? I installed urbackup on a windows pc (server) and two clients, all windows 10. Both clients did not manage to complete a backup after two weeks of trying. It is unbearably slow.

I also did disable background priority for the clients, but that did not help.

Currently the client shows me a time to complete the backup of 49 days.

This is a gigabit-network, so >100mb/s is no problem. But this is running with only some kb/s.

I also found these messages in the error log:

Could not read MBR

Cannot retrieve master boot record (MBR) for the disk from the client.

Backing up System Reserved (SYSVOL) partition failed. Image backup failed

I really want to use urbackup, but it is just not working :frowning:


#20

To summarize the reasons for slow backups previously mentioned in this thread:

Other reasons:

  • This can also happen if your server is slow, e.g. because your file system on the server is slow for small files (e.g. XFS) or you have an on-access virus scanner active on the server
  • Having backup with background priority enabled causes slow backup speed on some e.g. laptops with energy saving modes enabled.
  • Some people had to change Windows TCP settings. Disabling new congestion control algorithms or disabling TCP offloading