Very Slow Client Backup (50 KBit/s)

You don’t need Process Hacker or else for this. I did it in the normal windows task manager, right click on the running .exe and then set priority.

1 Like

That way you are setting the priority of the whole process. Individual threads will still have low IO priority. So you should redo that experiment with Process Hacker 2.

I tried again with Process Hacker and set every process and thread to high priority, but nothing changed.

I have this problem too!
30.03.17 11:06 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 1% finished 386.828 KB/23 MB at 52.728 KBit/s
30.03.17 11:07 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 3% finished 770.828 KB/23 MB at 52.352 KBit/s
30.03.17 11:08 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 4% finished 1.12776 MB/23 MB at 52.352 KBit/s
30.03.17 11:09 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 6% finished 1.50276 MB/23 MB at 52.352 KBit/s

30.03.17 11:34 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 47% finished 10.8764 MB/23 MB at 52.168 KBit/s
30.03.17 11:35 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 48% finished 11.2514 MB/23 MB at 52.352 KBit/s
30.03.17 11:36 DEBUG Loading “Users/User/AppData/Local/Google/Chrome/User Data/Default/History”. 50% finished 11.6264 MB/23 MB at 52.36 KBit/s
23 MB copied for an hour!

I have already used the advice, I installed the Hacker Process 2 and raised all the priorities to high and it did not help.

Same here:

16.04.17 18:54 DEBUG Loading “.symlink_SqlServerWriter_{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 53% finished 6.81388 MB/12.75 MB at 52.312 KBit/s
16.04.17 18:55 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 56% finished 7.18888 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:56 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 59% finished 7.56388 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:57 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 62% finished 7.93888 MB/12.75 MB at 52.32 KBit/s
16.04.17 18:58 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf". 65% finished 8.31388 MB/12.75 MB at 52.328 KBit/s
16.04.17 18:59 DEBUG Loading ".symlink_SqlServerWriter
{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}_80feb0461f85b69136f79b6d48885f40_msdb_files00000000/MSDBData.mdf”. 68% finished 8.69026 MB/12.75 MB at 52.512 KBit/s

If you change settings in advanced tab and set every local transfer modes same as internet transfer mode, it will be fast then…

I’m not sure about that, but when i change filesystem type to btrfs for backupstore, speed is avesome:

17.04.17 13:15 INFO Transferred 27.6498 MB - Average speed: 13.5473 MBit/s

I am having this problem since upgrading to latest Windows Server and Client versions with only 1 client.

It’s going to take days on this client to do a backup as the speed is showing/maxing out at about 1.5mbits.
I have run tests, and with this client doesn’t have problem transferring files to/from the server using Windows/shares.

I’ve been spending hours trying to figure out what’s the cause and haven’t come up with anything.

One thing I notice: if I filter process monitor on UrBackupClientBackend.exe, seems like there is a pattern (on larger files) of 4 TCPSend operations followed by 1 TCP Retransmit…

If you can, send me that (filtered) process monitor log.

Here is another one:

I will come back to this thread when this backup is finished :wink:

Sorry to not have replied -
I did find out that I did actually have a bad network cable! So, nothing wrong with Urbackup.

It looks like your client may be on Pause. If you right-click the UrBackup tray icon, do you see the word Pause or Continue there? (third word from the bottom)

5 Likes

Anyone ever found something regarding this issue ? trying to do internet backup of a server in our office to another location and hitting the same problem.

I know on my side it’s no bad network cable… servers are VMs

Thank you for the tip about it being paused. That is exactly what my problem was. Now I’m confused as to how it became paused. Oh well. Thanks again!

I’ve been in the same situation. You reboot the client service and it’s fast.

Is there a solution for this? I installed urbackup on a windows pc (server) and two clients, all windows 10. Both clients did not manage to complete a backup after two weeks of trying. It is unbearably slow.

I also did disable background priority for the clients, but that did not help.

Currently the client shows me a time to complete the backup of 49 days.

This is a gigabit-network, so >100mb/s is no problem. But this is running with only some kb/s.

I also found these messages in the error log:

Could not read MBR

Cannot retrieve master boot record (MBR) for the disk from the client.

Backing up System Reserved (SYSVOL) partition failed. Image backup failed

I really want to use urbackup, but it is just not working :frowning:

To summarize the reasons for slow backups previously mentioned in this thread:

Other reasons:

  • This can also happen if your server is slow, e.g. because your file system on the server is slow for small files (e.g. XFS) or you have an on-access virus scanner active on the server
  • Having backup with background priority enabled causes slow backup speed on some e.g. laptops with energy saving modes enabled.
  • Some people had to change Windows TCP settings. Disabling new congestion control algorithms or disabling TCP offloading

These 2 settings are mentioned in other threads that i am too lazy to find. They are located in the hardware configuration of the network card (driver settings):

  • Windows congestion control (For me it’s the single most effective setting).
  • Various tcp offloading (i can’t pinpoint if that’s a vmware specific issue)

Hello uroni

Thanks! But I could not figure it out yet. I have disabled the on-access scanner (windows defender) on the server.

What can I change to get this to work? I have no problem accessing other files on the server over the network.

Also Crashplan worked without any problems on the same server and clients. But with UrBackup none of the clients managed to get a backup to even 10% after two month.

I really want to use UrBackup because the featureset seems very nice, but it is just not working at all :frowning:

Thanks! I completly ignored that option! :slight_smile:

I have the same issue but it full disk C, because I install this software in disk C when I started backup file temp, will be full disk C. Someone know how to move this file temp Please Help me thanks