Save ALL : constructing of filelist failed (index/shadowcopy problem)

hy there !

here’s the log ! ( I turned on the debug level)

24.09.14 14:16 INFO Starting full file backup…
24.09.14 14:16 DEBUG yy-PC: Connecting for filelist…
24.09.14 14:16 DEBUG yy-PC: Waiting for filelist
24.09.14 14:18 WARNING Error getting volume path for ALL:
24.09.14 14:18 ERROR Cannot access directory to backup: "\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2:"
24.09.14 14:18 ERROR Constructing of filelist of “yy-PC” failed: error - index error
24.09.14 14:18 ERROR Backup had errors. Deleting partial backup.

For now (and before reinstalling all the pc), my backup method is "save everything except some directories and files), because the pc are really messy and the number of volume letter varies between 1 to 13…

Before discovering the new “all” parameter, I tried using “c:;d:;e:…up to m:” for all the pc but I got almost the same kind of message : the backup process wasn’t complete because I asked the client to save volumes that doesn’t exist.
I use the “ALL” parameter and it’s much better ! But, now, I discover that some computers have a problem with the “ALL” settings.

  • When I configure exactly the correct amount of volume letter computer by computer, the backup works

  • When I use the “ALL” parameter, the backup fails for some computer and works for some others…

  • I use urbackup server + client all in 1.4.1

  • I tried with a fresh install of win7 sp1 x64 -> same problem

  • it seems that it’s only with win7 32/64, the problem didn’t appear on winXP for now

  • I did a chkdsk /f _> same problem

  • tried to update windows - stop/start the volume shadow copy service - stop/start the urbackup -> same problem

  • checked the index service -> nothing special there

  • tried to empty the trash -> same problem

I still can’t find what create this problem, I’m feeling that it’s a system problem but I still can not find it :confused:

Thanks for your help
Dasti

The ALL parameter only works for the image backups and not for file backups. I’ll consider adding it for file backups as well. Meanwhile there is a hidden feature to not stop on index errors of a directory.
You have to give the backup folder a name and append /optional. That is for example
C:\|C/optional;D:\|D/optional|E:\|E/optional.

1 Like

Whaou ! Thanks for the tips ! It works perfectly

Just for you information, according to the results I have

  • the “all” parameter seems to work on windowsXP (no errors in the log) but, in fact, it just save the C: and not the other existing partitions
  • with the method you gave me, even if the drive doesn’t exists, the server will create the “renamed” drive folder (C D E F) in the backup and it will be empty
  • in the file copy parameters, the exceptions still works at 100%

my environment :

  • around 200pc
  • a mix of winXP 32/64 and win7 32//64 (with all kinds of updates level)
  • urbackup 1.4.1 on freenas 9.2.1.7

Thanks !

Hi,

How can I use this /optional parameter for linux configuration ?

eg.

/home;/root;/etc;/var/spool/cron;/SVN;

this is not working:

/home;/root;/etc;/var/spool/cron;/SVN /optional;

you need to set a name for the directory first…

/home|HOME/optional

Thank you.

I still get error “Errors no such file or directory” …don’t know why becuase if this is optional I shoulden’t have error …but warning.

But backup finishes.

Can you change in code to generate warning instead of error in this case in future release ?

For anyone interested: As an add on to uroni’s comment. This would be similar to ALL?
I would make C: not optional personally.

A:|A/optional;B:|B/optional;C:|C/optional;D:|D/optional;E:|E/optional;F:|F/optional;G:|G/optional;H:|H/optional;I:|I/optional;J:|J/optional;K:|K/optional;L:|L/optional;M:|M/optional;N:|N/optional;O:|O/optional;P:|P/optional;Q:|Q/optional;R:|R/optional;S:|S/optional;T:|T/optional;U:|U/optional;V:|V/optional;W:|W/optional;X:
|X/optional;Y:|Y/optional;Z:|Z/optional