In Progress;Testing required:Restoring to different hardware


#1

The situation:
Problem 1: Windows optimizes itself for a short boot time by disabling drivers which it does not need on the current harware. If one restores it to different hardware it then won’t be able to boot because the correct drivers are not loaded.

Problem 2: Windows sometimes does not have the correct driver to boot on different hardware at all. For example Windows XP does not have any AHCI driver per default.

The solution:
For problem 1 the restore cd now has a method to modifiy the restored Windows installation to reenable the relevant drivers.

Problem 2 remains unsolved for now, but I would like some feedback of how much of a problem this is.

Help testing:
The restore cd here http://sourceforge.net/projects/urbackup/files/Restore/1.1.1/urbackup_restore_1.1.1WIP.iso/download includes a first release of the method to make the restored Windows bootable on different hardware. It would be nice if we could investigate in which constellations (of hardware backed up and hardware restored to) this already works and which constellations still need work.

The option will appear on the last screen, after the volume is restored. See http://i.imgur.com/nZ9wspe.png?1


UrBackupWinServer service stops during restore
#2

Good afternoon, Martin, I’ve tried to do so, but only with Acronis. After the restoration sometimes necessary to restore your system using a disk Windows. In most cases, just to correct the boot loader (fixboot, fixmbr)


#3

The biggest problem I have encountered restoring to different hardware, (using other products), is if the new system uses a different hard drive controller or different raid controller then you will get the dreaded “Inaccessible boot device” error when starting up because the system image doesn’t contain the driver for the new controller. What I have seen in other universal restore products is the ability to inject the correct driver during the restore process. What I’ve always had to do when migrating working systems to new hardware is to use an add-in controller on the old system, load the drivers for the add-in controller, then take the system image. On the new system, attach the boot drive to this same add-in controller and perform the restore. Then the new system will boot because it has the drivers for add in controller. Once the new system is booted then you can install all the additional drivers for the new hardware.

The problem I have come across with Ver 1.1 of the restore cd is that the NIC drivers for the Broadcom 5720 controller which is in many of my Dell Servers appears to be broken and the restore CD can’t find the server even if I hard set an IP. From what I have read it’s an issue with the driver in the Debian release. I can’t get past that to see if the RAID controller would be supported. This doesn’t have to do with restoring on different hardware as I’m trying to test restore the backup image from the same machine.


#4

Hi Martin,

Wanted to let you know that I tested the restore process. It worked quite successfully.

Restored Server: Windows Server 2003
Ram: 512 MB
HDD: 74 GB

Restored to: Xen Virtual Architecture
Ram: 1024 GB
Virtual HDD Size: 200 GB

If you want any logs, etc. let me know. I will grab whatever you need. The only thing that I have noticed with the restore (and is also why my first restore attempt failed) is that at the very end, with the options to restart, make bootable, etc. the cursor defaults to cancel. I did not look and went to make bootable then hit enter. This canceled out and it did not work. The second time I noticed this and moved to OK and the restore went perfect.

Great work! Keep it up!


#5

Tested another restore, similar settings to the last time. Different server, 2003 SBS instead of enterprise. Worked like a charm. I will be testing a windows 7 box tomorrow and a server 2008 within the next week or so.


pinned #6

#7

I believe someone asked about a windows 7 restore on the other forum. I don’t see it so I assume it is one of the ones that went missing.

The windows 7 results are inconclusive at this time, the actual restore itself failed but I have reason to believe this was due to lack of hard drive space.

I have, however, moved onto testing the Server 2008 restore. More specifically, SBS 2008. The restore completed but is coming back with the 0x7B stop screen error. I am attempting to load the SBS 2008 install disk to run a repair as I feel the problem lies with drivers from the HD controller. I will report back after the repairs have been run.

SBS 2008 physical system:
Processor - Intel Xeon CPU X3440
12,888 MB Ram
2X WDC 232 GB HDDs

Test restore system:
XenServer host with Restore disc 1.1-WIP. 3000 MB ram. 430 GB VHDD. 1 VCPU.


#8

I’ve restored 2 different installs of Windows 7 Ultimate 64 bit onto 2 different ( dissimilar ) hardware setups with success. I just had to install the new hardware drivers afterwards, which is expected.

Windows 8.1 does not work, I would say due to UrBackup not recognizing the EFI boot partition. See attached.

.


#9

Did it boot, or did you have to do a repair install?

Yeah. EFI isn’t supported at this time. The setup is weird, too. I can count 3 “Recovery partitions” and 1 “System partition”. I wonder from which partition it boots. Can you post the output of sysvol_test.exe on that Laptop? (It shows debug info about the procedure which finds the Windows boot volume)


#10

I’ve now restored 3 different installs of Windows 7 onto 2 different hardware setups. I used the UrBackup restore disc Version 1.1.1, 03/02/2014 and selected the “make Windows bootable on different hardware” option.

Generic PC, Window 7 Ultimate 64 bit, AHCI enabled -> Booted with no repair.
Acer notebook, Window 7 Home Premium 64 bit, AHCI enabled -> Booted with no repair.
Generic PC, Window 7 Ultimate 64 bit, AHCI disabled -> Booted after Windows repair and had to leave AHCI disabled on target M/B.

The Windows 8.1 Notebook is from Acer. Perhaps those extra recovery partitions have been put there by Acer. I could not find sysvol_test.exe , is this a UrBackup client command line option?


Restore to Different Hardware
#11

Thanks for the info!

It’s at C:\Program Files\UrBackup\sysvol_test.exe per default.


#12

DEBUG: Filesystem. Vol="\?\Volume{1336c236-3d28-42eb-8330-a12a930c964a}" Name=“acer” Type=“ntfs” VPaths=1 Size=482840932352
DEBUG: Filesystem is System partition. Skipping…
DEBUG: Filesystem. Vol="\?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b}" Name=“recovery” Type=“ntfs” VPaths=0 Size=419426304
ERROR: GPT formated hard disk encountered. UrBackup does not support GPT formated hard disks! (Volume=\?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b})
DEBUG: Bootable flag not set for volume
DEBUG: Found potential candidate: \?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b}\ Score: 1
DEBUG: Filesystem. Vol="\?\Volume{f833470d-9151-4d5e-8312-f12a7741db90}" Name="" Type=“ntfs” VPaths=0 Size=366997504
ERROR: GPT formated hard disk encountered. UrBackup does not support GPT formated hard disks! (Volume=\?\Volume{f833470d-9151-4d5e-8312-f12a7741db90})
DEBUG: Bootable flag not set for volume
DEBUG: Found potential candidate: \?\Volume{f833470d-9151-4d5e-8312-f12a7741db90}\ Score: 1
DEBUG: Filesystem. Vol="\?\Volume{1b08500f-95f4-456c-8447-6f6f5151c9d7}" Name=“push button reset” Type=“ntfs” VPaths=0 Size=16030625792
ERROR: GPT formated hard disk encountered. UrBackup does not support GPT formated hard disks! (Volume=\?\Volume{1b08500f-95f4-456c-8447-6f6f5151c9d7})
DEBUG: Bootable flag not set for volume
DEBUG: Found potential candidate: \?\Volume{1b08500f-95f4-456c-8447-6f6f5151c9d7}\ Score: 1
DEBUG: Filesystem. Vol="\?\Volume{3997e349-c3ff-11e2-be6c-806e6f6e6963}" Name="" Type="" VPaths=1 Size=-1
DEBUG: Bootable flag not set for volume
DEBUG: Selected volume \?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b}
Found sysvol “\?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b}” Path: ""
Trying to open SYSVOL(\?\Volume{65a2f21b-e8db-4012-b6f6-954db2e8033b})…
Successfully opened SYSVOL.


#13

It would be great if there were an option when you boot the CD so that you can so the “restore to different hardware” if you have acciently forgotten to select it after the restore is conplete (otherwise you would have to to it all over again I guess)


#14

Though the topic is old, I presume it is still active. I have very similar problem.

Just for background, the 1.4.9 UrBackup server is built on Citrix XEN 6.5 VM of Debian 8.2 with shared NFS volume to a NAS4FREE ZFS RAID. So far everything works pretty fine and fast.

The problem that I am facing is when I am trying to restore a Windows Server 2008 R2 VM (running on the same host) from image backup to another VM (with different ID, but with absolutely the same order and size of HDDs and completely same settings for CPU, cores and numbers, and RAM.

So, the problems are:

  • If using Restore CD 1.1.2 - I cannot restore on a newly created HDD, for by any reason the restore engine is unable to create MBR/GPT on the hard drive. If I create the MBR myself, the restoration starts and stops after 1 % progress.

  • I took Restore CD 1.2WIP2 - with it everything went fine, just the OS shows BSOD with error 0x0000007B.

Up to my understanding there is something wrong with the controller initialization during the start up. I tried with and without the restore option for boot on another hardware, regretfully without success.

Interesting is that with HirenBoot CD I changed the Paravirtual driver to IDE and the BSOD disappeared, though the VM still does not start, but at least boots into safe mode. At first boot in safe mode, before replacing the VM HDD controller, Windows finds the QEMU HDD and XEN network adapter, but even after that during normal boot the BSOD appears again.

What I am doing wrong? Any advice would be more than welcome.

Friendly regards,

Alex


#16

The problem turned out to be caused by XEN. Opened a new post for informing everyone about how to, at the Restore section. Awaiting for the WIP to become final version of the restore CD.

All the best regards,

Alex