Working solution for snapshot mechanism under Linux?!

Does someone have a proper setup for robust Linux snapshot mechanism?
I tried LVM, mapper device and now dattodb without success. It is a ext4 filesystem with LVM and ubuntu 22.04.

2024-04-18 18:50:04: ERROR: Creating snapshot of “/etc” failed
2024-04-18 18:50:04: ERROR: Snapshotting device /dev/mapper/ubuntu–vg-ubuntu–lv via dattobd…
2024-04-18 18:50:04: ERROR: Using /dev/datto0…
2024-04-18 18:50:04: ERROR: CBT=type=datto&reset=1
2024-04-18 18:50:04: ERROR: Mounting /dev/mapper/wsnap-f73bc4d475ce1aa1d7b0bff88667d9f945c77416aafc4464…
2024-04-18 18:50:04: ERROR: mount: /mnt/urbackup_snaps/f73bc4d475ce1aa1d7b0bff88667d9f945c77416aafc4464: wrong fs type, bad option, bad superblock on /dev/mapper/wsnap-f73bc4d475ce1aa1d7b0bff88667d9f945c77416aafc4464, missing codepage or helper program, or other error.
2024-04-18 18:50:04: ERROR: Mounting filesystem failed
2024-04-18 18:50:04: ERROR: Creating snapshot of “etc” failed.
2024-04-18 18:50:05: ERROR: Creating shadowcopy of “etc” failed.

I was using datto for quite some time successfully but they did not release versions for more recent kernels for a while. When they finally did I could not get it to work anymore. I would recommend to stay away from datto unless someone else has better experiences with maybe more up to date versions.

I also know the error message but I could not get it fixed so I finally stopped using snapshots altogether.

1 Like

I have the same install and quite sure how to debug.
I was able to pinpoint it’s in the mount command. The other pieces of the script work ok.

  1. Sets up snapshot
  2. Creates loop device
  3. Mount loop device fails with the error you show.

Also make sure you setup a swap partition or similar smaller partition to backup as with the default installs creating 1 partition and a swap file really add volume to the datto snap files.

I see a huge volume growth with the binaries that support ubuntu 22.04 LTS

I would appreciate if you could share your setup/snippets here.

Mine doesn’t work either i get the same error… I setup a lab machine with 22.04 ubuntu fresh and installed the compiled dattobd packages I’m going to try and compile myself to see if that fixes but i’m not hopeful

1 Like

By the way: I also tried elastio (GitHub - elastio/elastio-snap: kernel module for taking block-level snapshots and incremental backups of Linux block devices) instead but I it did not work for me either.

Since I also got in trouble recovering an urbackup Linux image I will walk away from urbackup, which is a pity. To me, it appears to be a Windows backup platform and probably working well.