Linux recovery with dm snapshot device - troubleshooting

Yesterday I had to recover an ubuntu 20.04 VM guest using urbackup and the urbackup recovery image. I was facing some problems after I updated the system including the kernel, so I post my recovery after recovery here…

The picture attached shows that I ran into the initramfs prompt unable to find the boot root. After recovery I made a VM snapshot so I could reset the system to the state before the kernel update since I do not recommend to hassle around setting the boot root for GRUB and the kernel manually.

Repeating the update/upgrade I could see the GRUB update failed pointing to the devicemap. All root entries in the grub.cfg were pointing to the urbackup mapper device. I did

  1. Create a devicemapper file: >grub-mkdevicemap
  2. Checked the entries: >more
  3. Probed the OS: >os-prober
  4. Updated GRUB: >update-grub
  5. Installed the new RAM disk: >update-initramfs -u

Afterwards I was able to perform the kernel upgrade and reboot without problems.
But as assumed the dm snapshot device was gone and I uninstalled and reinstalled the urbackup client and selected option 4) device mapper. But as not expected there was no mapping device build. I tried to reboot, build new GRUB without success.

What is the idea behind here? If you are able to backup your client your not able to update the kernel but if you are able to update the kernel you are unable to backup your client!