Windows and Linux clients using “Access/Restore Backups” menu not showing files in browser

Hi there,
I am somewhat stuck and I do not know whether I missed a settings or I have not understood some principles with the web-based client restore functionality.
I work an Urbackup Server 2.2.11 on Debian/BTRFS and with clients in Version 2.2.6. I tested with Chromium and Firefox on the Windows and Linux client side.
However, if I use the client menu “Access/Restore Backups” in my Windows 8.1 PC or my Linux clients (Manjaro 17.x, Cinnamon and Debian 8, XFCE) it shows shows the chronological backup list ordered chronological but when clicking into one of the dates I see a rather blank page with just the option “Restore folder to client”. My expectation is, that I would see a list of files and folders with theo options “restore” and " List" as I do it when I access the Urbackup Server directly via http://XXX.XXX.XXX.XXX:55414/ >Backups>Clients>Client A…
Perhaps someone could guide me how to meet this expectations or correct my expectations.
Thanks in advance for any hints,
Windows 8.1:

Debian 8:


Same versions, no pb for me, i can browse the folders from the client.
I dont use btrfs, maybe that’s related to that.

There’s a bug with Mac client as well when accessing the backups with the pre-built menus:

Workaround till it’s fixed is to create a dedicated username and password and manually login to the server URL, then it’ll show you the files.

Thanks orogor and silversword for your hints!

@orogor: I made a fresh installation of UrBackup on Debian 8 with an EXT4 data disk instead of a BTRFS disk I used before. However, the issue remains the same with accessing the the backups via “access/restore backups” via the GUI of the clients. So now I ran out of option with Debian, so I do not want to use XFS or ZFS. What filesystem do you use for the backup disk?

@silversword: I learned that on MacOSX it seems to be the same issue that I observe on Linux and Windows clients. If this is seen as a bug, is it somewhere stated where the developers get aware of it? Perhaps I could file a bug report? Do you know more on this?

Thanks again for your time,

zfs, but i d be surprised if that’s the issue

Can you check the file permission? The urbackup user should have the permission to view the file through the WebUI.

Thanks GuGu for the suggestion.
I would love to do so, but at the moment I do not fully understand where I should check the file permissions for the urbackup user. Could you please explain it a bit in more detail where I have to look for?
Please pardon me but I am rather new in the UrBackup filed.
Thanks in advance,

From at the bottom of the page there’s an issue tracker link:

But looking at that tracker and some creative filtering, the last dev activity was Feb 2017. Either another bug tracker is being used or developer time is being redirected somewhere else. Uroni I think is the primary developer for Urbackup as far as I’ve been able to tell but he only intermittently responds to issues on these forums. I’ve tried contacting Urbackup to pay for support items but haven’t heard back.

I’ve found 2-3 definite bugs (this being one), but haven’t bothered writing up issues yet. This bug I’m pretty sure is related to how session state is tracked in the http admin pages and how access is given to clients with pre-generated single-use tokens in the URL for file access (as generated from the Urbackup menus).

Kinda feels like Urbackup is coasting atm IMHO

Sorry for my english
@wechsler As per your one of above picture, you are not able to view the client test64 files.
So you check the permission of test64 directory and files under the Urbackup Backup_Storage_Path like /Backup_Path/test64

Let see my setup


See here all directories are having the permission of urbackup user and group, If the urbackup user doesn’t have permission then you can’t access the files through the WebUI


It is a bit more complicated.
UrBackup translates the file (read) permissions to an operating system independent format on backup and stores them to .hashes.
When you click Access/Restore backups it takes the permissions of the user clicking and (theoretically) shows only the files the user could access at the time the backup was taken.
So this is a bit complicated and it works on the systems I have and that I am testing on.
You could try looking into the server log if it has metadata read error when trying to access files, investigate local file permissons w.r.t. to the user clicking access and try to access via admin user (e.g. by running the tray icon as Administrator user).
Also interesting would be if the users are e.g. LDAP/AD users. 2.2.x also had some changes in this area, so it would be also interesting if it works with 2.1.x clients.

Thanks gugu, sliversword and uroni for your hints.
@silversword: I found some further code repos which seem to be very recent where one could report issues: Urbackup Github. I share your view that the Atlassian repository seems to be somewhat outdated.
@GuGu: Thanks you very much for the hint with the permissions. I adapted the permissions as you suggested but unfortunately it did not change the situation for my clients.
@uroni: I learned that you are the main developer for UrBackup. Thanks for joining this topic and for your explanations. As a first trial, I used on Windows 8.1 the Administrator account and voilà: “Access/Restore Backups" works as expected. I logged in via the root account of my Debian 8 system and voilà: “Access/Restore Backups" works as expected. So for me the questions is now, how could I make it work with a standard user account on Windows 8.1 or with a non privileged user account on Debian 8/Gnome or Manjaro 17.x/Cinnamon clients? Do you need any log files etc. from me to sort it out?
Thanks in advance,

1 Like

As said, if there are errors in the log (server) files, that would be interesting. And you haven’t told us if you use LDAP/AD for your users.

Sorry uroni, I read your posting not careful enough.
I have only local users, no LDAP/AD users.
I attached the server debug log and the urbackupclientbackend debug log (Xubuntu 18.04, non-root user while clicking on “Access/Restore Backups” in the GUI) urbackupclientbackend_debug_log.txt (8.9 KB)
and the
urbackup_server_debug_log.txt (3.8 KB)
for further analysis. Just let me know if you need further logs etc.
Thanks for your help in advance.

Meanwhile I made some more trials but without any luck.
I prepared vanilla installations of the UrBackup 2.2.11 server on Ubuntu Bionic LTS (via the OpenSuse repo) and on Manjaro 17.x but still I face the problem that Windows and Linux clients using “Access/Restore Backups” menu not showing files in browser as non-privileged/non-administrator users. Honestly, I slightly ran out of ideas. @uroni perhaps you found some time for analyzing the debug log files I posted? Maybe there is hint to solve this issue.

There’s no hint in the log files. Will try to reproduce the problem…

Thanks uroni for the fast response. If I could help, let me know. Would it be helpful if I prepare a VirtualBox image (Urbackup on Ubuntu Bionic) and hand it over to you for analysis?

I think I found the issue with Linux/MacOS, but found no issues with Windows clients.

Thanks uroni for the good news. Just let me know if you need some testing capacity for Linux. I will double-check the situation on Windows and report back. For MacOSX perhaps @silversword might help with testing.

Hi uroni,
I made again some test on vanilla Windows platforms. I worked with an Urbackup Server 2.2.11 on Debian/BTRFS and with clients in Version 2.2.6. I tested with IE and Firefox on the Windows side:

  • Windows 8.1, up-to-date patch state: Client 2.2.6 works without issues as far as I can see on administrator and on non-privileged user accounts.
  • Windows 10 build 17.09, up-to-date patch state: Client 2.2.6 works without issues as far as I can see on administrator and on non-privileged user accounts.

I think I messed up somehow the installation of the Urbackup Client in my first trial - Sorry for that.
However, the issues on MacOSX and Linux platform are confirmed and fixed, so I dare to ask when we could expect an update of the server. Do you have already some plans on it?
Thanks again to all in this thread for the help!

Hi @uroni and @silversword,
I have tested the new Server 2.3.1 beta/Client 2.3.0 beta combo on a vanilla Xubuntu 18.04 LTS platform with regards to the client issues stated in this thread. I installed the beta client according to “Install client on Debian or Ubuntu from sources”. I have good news: The Linux client using “Access/Restore Backups” menu works now as expected, so I could restore files or directories etc. via Browser as an admin user as well as a non-privileged user on the Xubuntu system.
Thanks a lot for fixing the issue on Linux and I hope the results are the same on the MacOSX side of life.