Version 2.5.25 an virtual clients


I recently updated to 2.5.25 and I am currently having some trouble getting the virtual clients to work.

I have one ubuntu machine with one virtual client. The non-virtual client works fine. The virtual client however is online but has issues with the server authentication (online status in the German UI is " Ja (Fehler bei der Serverauthentifizierung)".

In the client logs I see these error messages:

2022-09-05 20:42:01: ERROR: Client requires encryption which server does not offer
2022-09-05 20:42:11: rc=0 hasError=true state=0
2022-09-05 20:42:11: ClientService cmd: #Is9dOYvS3mAUHpSFS3AbD#GET CHALLENGE clientsubname=cloudstorage

I don’t see anythin suspicious in the server logs.

I tried to create a new virtual client but this one does not come up in the UI at all. Instead I see the same error messages in the log. Since the non-virtual client works just fine it seems that authentication is not a general issue though.

Please let me know if I need to provide more information. I could not find any clues in the admin manual nor in the forums so far.

Thanks for any input!

Can confirm that this is happening in my installation (Docker server) as well. Could not get virtual clients to work. Removing also leaded to the same issue, that I now don’t get the new virtual client any more.

Thanks for your input! I don’t run a docker based setup btw.

Server version 2.5.26 seems to have fixed it for me. At least my newly created virtual subclient seems to work fine (currently indexing…), the one that was existing before does not seem to backup but at least the error message is gone.

So subclients do work again, thanks for this quick fix!

One thing I noticed: while the prefilebackup scripts are still called with the same virtual subclient ID as before, the postfileindex script seems to be called with the subclient ID multiplied by 10.

$3 of prefilebackup: 100
$3 of postfileindex: 1000

The same applies for subclient 200