UrBackup v2.1.19 fails to install in a clean Jail (FreeNAS v11.0-U2)


#1

Hi All,

I’m trying to install UrBackup (v2.1.19) in a fresh Jail, on v11.0-U2, and am following the instructions laid out at: https://www.urbackup.org/freenasserverinstall.html, i.e.

pkg update
pkg install cryptopp
curl -O https://hndl.urbackup.org/Server/2.1.19/urbackup-server-2.1.19.tar.gz
tar xf urbackup-server-2.1.19.tar.gz
cd urbackup-server-2.1.19
./configure
make install -j4

But, I’m getting some errors and it fails to install after I use the make install -j4 command:

chown urbackup:urbackup "/usr/local/share/urbackup"
chown: urbackup: illegal group name
*** [install-data-local] Error code 1

make[2]: stopped in /urbackup-server-2.1.19
— install-exec-local —
pw useradd urbackup -q -g urbackup -d “/usr/local/var/urbackup” -m -s /usr/bin/false || true
chown urbackup:urbackup "/usr/local/var/urbackup"
1 error

make[2]: stopped in /urbackup-server-2.1.19
*** [install-am] Error code 2

make[1]: stopped in /urbackup-server-2.1.19
1 error

make[1]: stopped in /urbackup-server-2.1.19
*** [install-recursive] Error code 1

make: stopped in /urbackup-server-2.1.19
1 error

make: stopped in /urbackup-server-2.1.19

Anyone got any ideas?

Yours
Jonathan


#2

So, I tried something different this time. After I ran pkg update and before I ran pkg install cryptopp, I did the following:

pw addgroup urbackup
pw useradd urbackup -q -g urbackup -d “/usr/local/var/urbackup” -m -s /usr/bin/false

(copying the useradd from the error output above)

Then I continued with the install, this time I don’t get any errors, but I’m unable to connect to it via 192.168.x.xxx:55414

Bah!

Yours
Jonathan


#3

Is the UrBackup server service actually running?
Try urbackupsrv -v debug run


#4

Can someone confirm that user/groupadd needs to be changed on FreeBSD?

From

pw groupadd urbackup -q

to

pw addgroup urbackup -q

?


#5

Hi Yes, seems I forgot to start the service /blush. All working now.

Must be something funny in the install script which stops user/group adding as expected.

Jonathan


#6

I just done a test, and both commands seem to work.

Jonathan


#7

Hmm, then the question is why it failed the first time…


#8

Same here.
[root@freenas ~]# pw groupadd
pw: group name required
[root@freenas ~]# pw addgroup
pw: group name required
[root@freenas ~]#

Thats 10.3-STABLE
Seems FreeBSD is more versatile than ever these days.


#9

Maybe the group didn’t exist when chown was issued…


#10

So it has a delayed group creation feature :wink:


#11

LOL. Who knows…
I just read the title for this thread again. I see he’s using v11. I’ve not taken the plunge yet.
Maybe it’s a bug.


#12

@Hazimil I’m having same issue, coming up with many errors.

Do you have any guide how you did it…?

These are the issues I’m having.

Hoping if someone have any idea how to solve this puzzel

Thank you
:slight_smile:


#13

You just commited mass thread necromancy. It is unlikely your issue has anything to do with the issue in this thread (after 2 years…). If you do that again you will be permanently banned.


#14

thanks for your reply, actully i was looking for information and couldn’t find anywhere :frowning: .

and few post i found with similer issue. i didn’t meant to flood forum with my so many threads.

Cheerss