Urbackup Server dont find Debian-Client


#1

Hello, Im from Germany. Please look over mistakes, my English is not good.

I have a problem connecting a Debian client to the UrBackup server:

UrBackup-Server Windows Server 2016 Version 2.1.19
7x Debian Client 8.8 Jessie Version 2.1.16
All on the same Subnet, no firewall or other things which could disturbed are ther :confused:
I can NOT reinstall debian on the client…

Only one client cant connect, other clients are fine.

Steps which i tryed to solve the problem:

  • try to uninstall the client, and install it again
  • try to find a information from the logs, but they dont are usefull for me
  • try to Debug (Having problems with UrBackup? Please read before posting) but nothing happens, no debug.log is after a restart there
  • Type IP / hostname on server for Client-Discovery but it say first ONLINE after a few minutes OFFLINE and nothing happens (is this only a PING or what does it say?)
  • i restartet Client and Server a few times
    If i type this “urbackupclientbackend -v info” i got following message:
    user@myclient:~$ sudo urbackupclientbackend -v info
    [sudo] password for user:
    2017-06-20 10:15:31: ERROR: urbackupserver: Failed binding socket to port 35623. Another instance of this application may already be active and bound to this port.
    2017-06-20 10:15:31: Started UrBackupClient Backend…
    2017-06-20 10:15:31: ERROR: Binding tcp socket to port 35621 failed. Another instance of this application may already be active and bound to this port.
    2017-06-20 10:15:31: ERROR: FileServ exit with error code: 99
    2017-06-20 10:15:32: Looking for old Sessions… 0 sessions
    -> I solved this, with kill the process, and reinstall urbackupclient:
    sudo urbackupclientbackend -v info
    2017-06-20 11:33:57: SQLite: recovered 24 frames from WAL file /usr/local/var/urbackup/backup_client.db-wal code: 283
    2017-06-20 11:33:57: urbackupserver: Server started up successfully!
    2017-06-20 11:33:57: FileSrv: Servername: -clienthostname-
    2017-06-20 11:33:57: Started UrBackupClient Backend…
    2017-06-20 11:33:58: Looking for old Sessions… 0 sessions

But nothing happens on a new try for auto-discover… :frowning:

serverlog.log (170,5 KB)

What can i do :frowning: Please help me, i rly dont know what the problem is.


#2

clientlog.log (7,9 KB)


#3


#4

Try to click on “show all clients” at bottom left.
Also on show/hide columns, show everything
If there s an unreconised client one of the column has a message about missing server idents.

if so, get server_idents.txt from another client and copy it over the problematic one then restart the client

if the client is on the same subnet, with no firewall and the discovery is working properly (via udp broadcast every minutes), it should show up when you click all clients, even if the server ident is bad

if it s on the same subnet , you can remove the discovery, it s usefull mainly for clients not on the same lan than server.


#5

Hello orgor,
thank you for ure answer. I click on “show ll clients” and i dont see mein lost client.
Who can i find the problem? I rly dont know what i can do, because the logfiles dosnt say anything about the connection to the server :frowning: I cant help myself without any hint :frowning:

I work on this problem since 16 hours and i have no step to solve this.

Any idea?


#6

i guess the agent process is running if you use ps axf?
Did you tried telnet/nc to test if ports were open?
https://www.urbackup.org/administration_manual.html#x1-9000010.3

Something you can try is assume something is odd with the network.

Both on web ui
On server setting, enable internet mod
On the client config make sure internet mode is enabled
Restart the server

In status page, you can use “download client linux”, and select the client.
This generate a file that will install a preconfigured agent
(should be compatible with the wget 3 lines install that you get on the website, not so sure if it s compatble with an agent you compiled yourself)


#7

Hello orogor,
i see on my failed connected client this (same on the connected):
tcp 0 0 0.0.0.0:35621 0.0.0.0:* LISTEN 592/urbackupclientb
tcp 0 0 0.0.0.0:35623 0.0.0.0:* LISTEN 592/urbackupclientb

So i think the ports are fine.

I enable internet mod, but i cant select the client if the client is not there :frowning:
Can i edit the file and rename the servername to my client?


#8

maybe run uninstall_urbackupclient or make sure to fully remove the client

These should show the urbackup files
find /etc/ -iname "urbackup"
find /opt -iname "urbackup"
find /usr/local/ -iname “urbackup”

click on add client (At bottom right, but above discovery)
select add new client, client behind nat

i just tested and on the next page it will give you a command to copy paste to install it.

“Download preconfigured client installer for Linux
Install it directly in the terminal via: xxxxx”

This should get you a preconfigured client of the good version that works even if not on same lan.
Internet mode doesn t works exactly like lan mode, but if it works, it’s good


#9

Nothing works. I had to reinstall the system new. Thats was rly complex, but i had no choice :frowning: . now it works good, but this is not the solution.

ty for ure help.


#10

And now, i have got the same problem again. But i cant reinstall it. (client 2.2.5)


#11

Ok

Can you post again the clisnt logs wit the debug option set ?