UrBackup Server 2.1.13 beta/Client 2.1.10 beta

Major changes with server 2.1.x beta

  • Groups for client settings
  • Ability to reconnect during indexing if connection is broken
  • Define which volumes need to be snapshotted together (snapshot groups)
  • Image backup mounting, browsing and archival on Windows, Linux and FreeBSD (does not work in FreeBSD jails and with VHD/VHDZ on FreeBSD)

Major changes with client 2.1.x beta

  • Ability to reconnect during indexing if connection is broken
  • Improved image backup performance
  • Windows Backup API support (tested backup and restore with Microsoft SQL, tested backup with Microsoft Exchange and Hyper V)
  • File backups and restores use the change block data from the change block tracking driver now (you can install the beta client over a CBT client and this will work)
  • Define which volumes need to be snapshotted together (snapshot groups)

Changes with server 2.1.13 beta

  • Fix ZFS image backup deletion
  • Update SQLite to 3.16.1
  • Send server token on image backup resume such that the clients cleans it up properly after backup

Changes with client 2.1.10 beta

  • Fix download thread freeing (fixes crash after restore)
  • Continue snapshot clean-up after first failure (fixes shadow copy clean-up in some cases)

Upgrade process

As always: Replace the executables (via the installers) and the database of the server/client will be updated on first running it.

Place the files from the update directory into C:\Program Files\UrBackupServer\urbackup or /var/urbackup to auto-update clients. Disable Download client from update server in the server settings to prevent the server from downloading the current version.

On Linux e.g. with this update script: https://github.com/ptempier/get_urbackupclient/blob/master/updateclient.sh

Downgrade process (server)

Stop the UrBackup server, restore C:\Program Files\UrBackupServer\urbackup or /var/urbackup from a backup before upgrade and then install the previous version over the beta release.


cd /var/urbackup && wget -r -l1 --no-parent --reject “index.html*” -nH -nd -N “https://ssl.webpack.de/beta.urbackup.org/Client/2.1.10%20beta/update/

This doesn’t seem t work with this site. Whenever run it, I get the following:

cd /var/urbackup && wget -r -l1 --no-parent --reject “index.html*” -nH -nd -N “https://ssl.webpack.de/beta.urbackup.org/Client/2.1.10%20beta/update/
–2017-01-09 12:25:49-- https://ssl.webpack.de/beta.urbackup.org/Client/2.1.10%20beta/update/
Resolving ssl.webpack.de (ssl.webpack.de)…
Connecting to ssl.webpack.de (ssl.webpack.de)||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 845 [text/html]
Saving to: ‘index.html’

index.html 100%[=======================================================================================>] 845 --.-KB/s in 0.01s

Last-modified header missing – time-stamps turned off.
2017-01-09 12:25:50 (82.7 KB/s) - ‘index.html’ saved [845/845]

Loading robots.txt; please ignore errors.
–2017-01-09 12:25:50-- https://ssl.webpack.de/robots.txt
Reusing existing connection to ssl.webpack.de:443.
HTTP request sent, awaiting response… 200 OK
Length: 36 [text/plain]
Saving to: ‘robots.txt’

robots.txt 100%[=======================================================================================>] 36 --.-KB/s in 0s

2017-01-09 12:25:50 (19.5 MB/s) - ‘robots.txt’ saved [36/36]

Removing index.html since it should be rejected.

FINISHED --2017-01-09 12:25:50–
Total wall clock time: 0.9s
Downloaded: 2 files, 881 in 0.01s (86.2 KB/s)

Deleting the files and getting them manually works though:eg:


Removed the line. I just copy&pasted it from someone who claimed it worked.

It used to work fine with https://www.urbackup.org, it just seems like something weird happens with https://ssl.webpack.de

Bug Report:
fresh installation of server 2.1.13 and Client 2.1.10
Server shows it started a full file back and it is indexing and then hangs there for ever. Checked the windows client and found the urbackup service is stopped.

Did a reboot of client, it seems working after that.

Bug 2:

Backup C:\Users; one full file backup + one incremental
after that created a text file on Desktop;
then perform a restore of C:\Users based on full file backup, Turned out that newly created text file was NOT removed from the Desktop (Should be removed).

Could you add a little bit more information? For crashes e.g. the crash dump, for other problems the log files?

Since upgraded few servers from 2.1.11 or 2.1.12 to 2.1.13, all instances displayed an error after the cleanup phase :

Server’s log :

2017-01-10 12:56:17: Checking integrity of backup_server.db
2017-01-10 12:56:17: ERROR: Integrity check failed
2017-01-10 12:56:17: ERROR: Database integrity check failed. Skipping Database backup.

I will reproduce the issue and post/send the data. What do you need? I need a little bit time to complete the re-test

Well, I did update SQLite to the newest version. Can a hardware defect be excluded (i.e. is the database on ZFS or btrfs?)

I think we can exclude a hardware failure, it happens on the 4 servers i’ve updated, 2 with ZFS backend and 2 with BTRFS …


Ok, can you try with the SQLite shell from https://sqlite.org/download.html . The previous version is at https://www.sqlite.org/2016/sqlite-tools-linux-x86-3150000.zip

PRAGMA quick_check;

Ok got the issue. Sorry.

Just testing on /var/urbackup/backup_server.db :

root@backup-3:/usr/local/sqlite-tools-linux-x86-3160200# ./sqlite3 /var/urbackup/backup_server.db
SQLite version 3.16.2 2017-01-06 16:32:41
Enter ".help" for usage hints.
sqlite> PRAGMA quick_check;

Just reporting the same issue here 2.1.13:

I guess I should add some useful info: server is on Debian 8.6 / BTRFS

I run a clean install on Debian 8.6 for server 2.1.13. And 2.1.10 no tray on a clean windows 7. Right after installation, Server started a full file back and Client service stopped.
Debug file:
2017-01-10 19:51:07: ERROR: Recvfrom error in CUDPThread::UdpStep
2017-01-10 19:51:07: ERROR: Last error: 0
2017-01-10 19:51:07: ERROR: Fatal exception code 3221225477 at address 0x000007FEF2286614
2017-01-10 19:51:07: ERROR: Fatal exception (APPLICATION CRASHED). Crash dump written to “C:\Windows\TEMP\UrBackup\v2.0.0-20170110-195107-2636-2684.dmp”
2017-01-10 19:51:07: ERROR: Program abort (SIGABRT)

VolumeShadowCopy groups are deleted correctly now with client 2.1.10, thanks !
But got a new error this morning on few VMs :

After checking on the client when the error happens, shadowcopy was still present and wasn’t deleted.


I have the same issue with 2.1.13: “An error occured while accessing or checking UrBackup’s internal database. This means this database is probably damaged or there is not enough free space. If this error persists, please restore the database (the files backup_server.db, backup_server_files.db, backup_server_links.db, backup_server_link_journal.db and backup_server_settings.db) from a backup. See log file for details.”

Looks like it happened early this morning:
2017-01-11 03:40:54: ERROR: Error downloading dataplan database: HTTP response code said error(ec=22), The requested URL returned error: 404 Not Found
2017-01-11 03:40:55: ERROR: No permission to access “/storage/pi”
2017-01-11 03:46:44: ERROR: Integrity check failed
2017-01-11 03:46:44: ERROR: Database integrity check failed. Skipping Database backup.

The “pi” client error might be due to me creating a new client with that name in the Web UI, deleting it and then installing the beta client and connecting via LAN. This directory exists:
drwxr-x— 1 urbackup urbackup 124 Jan 11 07:41 pi?

  • Debian GNU/Linux 8.4 (jessie)
  • Upgrade from stable
  • BTRFS storage


after install i gott Failed binding SOCKET to Port 55413

urbackupsrv run
2017-01-11 11:35:40: Starting HTTP-Server on port 55414
2017-01-11 11:35:40: HTTP: Server started up successfully!
2017-01-11 11:35:41: Started UrBackup…
2017-01-11 11:35:41: Removing temporary files…
2017-01-11 11:35:41: Recreating temporary folder…
Testing for btrfs…
Create subvolume ‘/media/BACKUP/urbackup/testA54hj5luZtlorr494/A’
Create a snapshot of ‘/media/BACKUP/urbackup/testA54hj5luZtlorr494/A’ in ‘/media/BACKUP/urbackup/testA54hj5luZtlorr494/B’
Delete subvolume (commit): ‘/media/BACKUP/urbackup/testA54hj5luZtlorr494/A’
Delete subvolume (commit): ‘/media/BACKUP/urbackup/testA54hj5luZtlorr494/B’
2017-01-11 11:35:42: Backup destination does handle subvolumes and snapshots. Snapshots enabled for image and file backups.
2017-01-11 11:35:42: InternetService: Server started up successfully!
2017-01-11 11:35:42: UrBackup Server start up complete.
2017-01-11 11:35:42: Looking for old Sessions… 0 sessions
2017-01-11 11:35:42: ERROR: Failed binding SOCKET to Port 55413
2017-01-11 11:35:42: ERROR: Error while starting listening to ports. Stopping server.
2017-01-11 11:35:42: Exited Loop
2017-01-11 11:35:42: Deleting at…
2017-01-11 11:35:42: Deleting SelectThreads…
2017-01-11 11:35:42: Deleting lbs…
2017-01-11 11:35:42: Shutting down plugins…
2017-01-11 11:35:42: Deleting server…
root@debian-urpcs:/home/pcs# MOUNT TEST OK