Urbackup Hyper-V Client 2.2.19 does not work with Windows 10 anymore?

Hi ,

I currently am able to make an image backup from a fresh install of Windows 10.
I do use the Hyper-v client 2.2.19

But i can’t backup the vms anymore?
It does try to start but then suddenly dissapears.
Before on the same computer on Server 2016 i could backup all the machines.

Can this be fixed?
Windows 10 build 1909

Sorry you are having issues. To solve the problem the client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting


Sorry i fixed it!
I did not set the executionpolicy to unrestricted in Powershell.
So it could not load the hyperv_snapshot.ps1

I guess it should call powershell.exe with -ExecutionPolicy Bypass to avoid this…

By default it doesn’t

So after i ran the command set-executionpolicy unrestricted.

The client started to snapshot vms again.

What I meant was that the client calls powershell.exe .\\hyperv_snapshot.ps1 ... and I’ll change that to powershell.exe -ExecutionPolicy Bypass .\\hyperv_snapshot.ps1 with the next version so the problem you had is avoided…

nice , thanks