Urbackup Bus Error database out of space

Whenever my server crashes the debug log says Bus Error and/or database full. After several tests it seems to be crashing after backup_server_files.db or backup_server_files.db-wal reach 1GB in size. The log file has grown over 1GB so I know it isn’t a file system limit. I am running raid10 with 8tb free space and btrfs for my backup location and I have a 256GB ssd for my tmp files and the database with 200GB+ freespace. Is there a way to change the size limit of the database? I have attempted to change the pragma settings but they seem to be reversed.

Sorry you are having issues. To solve the problem the server (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the server to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting


After the following it would load/hash a few more files and then crash, and I would have to restore the db. This is taken from a log level set at debug. The full log is over 1GB.

2019-07-13 13:37:57: GT: Loaded file “report1618886066047179226txt”
2019-07-13 13:37:57: Loading file “report1618926412560669196txt”
2019-07-13 13:37:57: PT: Hashing file “report1618886066047179226txt”
2019-07-13 13:37:57: ERROR: Error in CQuery::Execute - database or disk is full Stmt: [INSERT INTO files (backupid, fullpath, hashpath, shahash, filesize, rsize, clientid, incremental, next_entry, prev_entry, pointed_to) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]
2019-07-13 13:37:57: GT: Loaded file “report1618926412560669196txt”
2019-07-13 13:37:57: PT: Hashing file “report1618926412560669196txt”
2019-07-13 13:37:57: Loading file “report1619109120029473949txt”

I also get this:
An error occured while accessing or checking UrBackup’s internal database. This means this database is probably damaged or there is not enough free space. If this error persists, please restore the database (the files backup_server.db, backup_server_files.db, backup_server_links.db, backup_server_link_journal.db and backup_server_settings.db) from a backup. See log file for details.

So it turns out that it is a disk full. I had used bind to mount /var/urbackup to my storage location which worked but it was still using the space limitations of my root directory. Is there a way for me to change /var/urbackup so that it wont be limited or install it in a different location?

Using a symbolic link worked. The following steps may help someone else along the lines.

  1. make back up of /var/urbackup with cp /var/urbackup/* /dir/of/backup -rf
  2. remove /var/urbackup with rm /var/urbackup -rf
  3. create a symbolic link to where you want the database with ln -srf /dir/where/you/want/database /var/urbackup
  4. copy backup of database back (technically to the new location now) with cp /dir/of/backup/* /var/urbackup/ -rf