Updated compile instructions

@uroni, do you have updated instructions for compiling UrBackup? I have finally had some time to work on it today, and the instructions at https://urbackup.atlassian.net/wiki/display/UC/Compiling+UrBackup+Client+for+Windows are not even in the ballpark now for 2.x versions of the source code.


I am having trouble setting up a dev machine as well.


What issues are you having? Clone the backend repo, clone the frontend repo in to a folder in the backend named “client”, run update_deps.bat and you should be able to compile everything. Are you able to get that far? Or are you working off a non-Windows platform?

Clearly it is not that simple to compile the system.
There are many many details need to be adjusted and many need are outdated.
for example, front end and Client 2.0.36RC is not available; update_deps.bat does not collect the libs… you have to get them manually by yourself.

Yes it is. I rebuilt a machine today and I followed those simple steps and had UrBackup compiling.

Like what? Seriously, I rebuilt my Windows dev machine today and I did none of that.


I am going to take a guess that 2.0.36RC is just the “next” branch. @uroni has not tagged that milestone yet, but he probably will soon.

Have you installed Git? Is it in your path? If you open a command prompt and type git status, what do you see?

Hi all,

I just try to build Urbackup but failed.
I clone the backend repo and frontend repo, then run update_deps.bat and run build_client.bat in (backend project).
My Build_client.bat result is failed because i lack of Win2003/vss.h . I install Microsoft VSS SDK and copy source code (vss.h, vss.cpp …) into deps/include. But I don’t know where to place vss lib file ? I try to move lib file to deps/lib/vssapi.lib (win2003 lib) => build result failed, with 3 errrors:

 "E:\Work\Test2\urbackup_backend\UrBackupBackend.sln" (default target) (1) ->
    "E:\Work\Test2\urbackup_backend\urbackupclient\urbackupclient.vcxproj" (default target) (5) ->
    (Link target) ->
      client.obj : error LNK2001: unresolved external symbol _VssFreeSnapshotPropertiesInternal@4 [E:\Work\Test2\urbackup_b
      client.obj : error LNK2001: unresolved external symbol _CreateVssBackupComponentsInternal@4 [E:\Work\Test2\urbackup_b
      E:\Work\Test2\urbackup_backend\Release\urbackupclient.dll : fatal error LNK1120: 2 unresolved externals [E:\Work\Test

Could you show me some advice to build Urbackup ^^


What version are you trying to build? The VSS files are unnecessary on 2.x. Just manually compile the versions you need and build the installers.

I am going to guess you have never worked in software before?

Hello All,

I have just downloaded de deps, yesterday, for some reason they didn’t download, but I have them now, still I cant compile getting some weird errors.

do I have to install all the packages needed, nsis, wxwidgets, cryptolib, etc?

if so, what versions should I use ?

Thanks everyone!

Those are all in the deps folder.

1 Like

I did manage to compile version 2.0.33 (or something similar ) sometime ago. The major problem is deps folder cannot be downloaded at the time when I worked on it. I had to manually create all the .h and libs, which is a pain.

One thing that still puzzled me at the time is that the resulted exe does not work on Win 7 (with many DLL’s missing).

When I get some time, I may post the procedure( I have a brief note written, but in another language) if anyone is interested.

The deps folder just takes forever to download. It is also infrequently updated, so you typically just copy it over.

I have formatted my PC, and things look better now, but still no go.
I will keep looking into this, and post an update

Walk me through the steps that you are going through to compile UrBackup, and what errors you are running in to?


everything looks better but still have errors…

first thing first, I downloaded urbckup_backend fine, and urbackup frontend
wx fine, (cloned into folder client)
downloaded deps (takes a long but it goes ok)

then in the urbackup_backend folder there is a build_client_backend.bat if
I run this crashes with errors… ‘win2003/vss.h’: no such file or
directory… and it does build nothing

if I go to urbackup_backend\client
and run build_client.bat

it starts to run then crashes with error …\data\urbackup_server03.dll is
not found
that is where I am stucked…

what am I doing wrong??

BTW I have a clean PC win10 x64, with vs2015 community edition, nsis and
wix3.10 installed

Thanks for your help

I do not use the batch files. I just manually compile and then run the NSIS installer scripts.

All of those files (win2003/vss.h, etc.) are unneeded and superfluous with 2.x. as it does not support XP and Server 2003.

I do believe that @uroni was going to fix the batch build and VSS requirements and remove them from the scripts for 2.1.x. Have you tried switching your branch to “dev” and seeing if it builds?


I will give this a try, and let you all know asap!

Thnks for the tip!

After you clone the repos, change the branch to “dev”, that should remove all the VSS dependencies.


that worked, I could compile the dev branch, without issues, just one more
question, do you know how do I get rid of the $version short$ ??

there is a python script which does the job to replace the $version xxxx
it is in the build_client.bat

Replace it.

Or, if you do not want to deal with getting Python to do so, just do a find and replace on that folder.