Synology package

I’ve compiled for armadaxp architecture and package the UrBackup Server for Synology DSM 5.2. The result is UrBackupServer-armadaxp-1.4.9.spk.

The how-to is documented on my blog post

If someone is interested for package for other architecture I will try to compile & package.

1 Like

This thread is now linked to from the download page. Thanks for creating the package/build instructions!

I have added urbackup server support to spksrc

spksrc is a cross compilation framework intended to compile and package software for Synology NAS devices.
Steps to make a package:

  1. checkout https://github.com/josef109/spksrc.git urbackup branch to a linux system
  2. ‘cd spksrc’ and ‘make setup’
  3. ‘cd spksrc/spk/urbakup’ and ‘make arch-xxxxx’ xxxxx for your synology nas
    for instance ‘make arch-armadaxp-6.1’ for a RS814 with DSM 6.1 to generate urbackup server 2.4.12
  4. goto synology nas and install manuell the spk from packages directory on your build system

see also https://github.com/SynoCommunity/spksrc/wiki/Developers-HOW-TO

1 Like

It would be cool if the binaries would be build via a free build service such as Azure Pipelines or travis (Azure piplines might be the one that stays around longer), such that there are binaries to link to from the download page.

Edit: Or I guess, it’s simply merged back into the synocommunity thing and becomes available via that.

It reads the default backup storage location from /etc/urbackup/backupfolder or WORKINGDIR/urbackup/backupfolder (/var/urbackup/backupfolder) (https://github.com/uroni/urbackup_backend/blob/dev/urbackupserver/dllmain.cpp#L697 ) btw. so you can use that to set the backup folder from package setup.

You should also perhaps set /etc/urbackup/backupfolder correctly as well, because I believe Synology uses btrfs, and if btrfs-tools is installed urbackup might be able to use btrfs-mode on Synology?

I hope so. I have send a pull request

Yes, I didn’t see that.
Changed it and works perfekt. Thank you :laughing:

Downloadlink Urbackup-server 2.4.12
https://github.com/josef109/spksrc/tree/urbackup/packages

Great!

But now they’ll have problems merging this since there are binaries in git :confused:
The proper way to do this is to tag a commit in git (e.g. as urbackup-2.4.12), then go to the releases tab in github -> edit release -> attach binary. I’m sure github would like me linking to releases more as well :slight_smile:

Like this https://github.com/uroni/spksrc/releases

Here is the new link :grinning:
https://github.com/josef109/spksrc/releases

2 Likes

Hi:

Thanks for putting this together; so far I have been using Urbackup Server inside Docker inside my Synology - and generally it has worked well.

I’m a bit puzzled as how to best move forward though:

  • Inside Docker, I can update to the latest Urbackup Server release as I choose;
  • With the spk release, it looks like I’m limited to whatever build is available in that format - but it looks like it has access to the BTRFS advantages;
  • I’m also a bit wary as to how cleanly the spk can be removed from the NAS, should I choose to.

Any advice that Those Who Know can impart?

Thanks!

Never change a running system :wink: I guess not all Synologies support docker?

I don’t think it sets /etc/urbackup/backupfolder, so btrfs support doesn’t work, correct?

Haha! Well - I’ve actually not been using it for a while, whilst the macOS client issues get sorted out - but I’d been happy with the server side running inside Docker when I was running it. :slight_smile: I’ll likely be blowing away my current setup and starting again from scratch, when I get to it.

I’m no Docker expert, but I’ve got the following paths linked to /volume1/docker inside the NAS:

/volume1/docker/urbackup-server/log         /var/log
/volume1/docker/urbackup-server/database    /var/urbackup
/volume1/docker/urbackup-server/backups     /backups

…with my Settings > Backup Storage Path set to /backups.

In the startup log, I see this:

2020-06-18 13:02:57: Image mounting disabled: TEST FAILED: guestmount is missing (libguestfs-tools)
2020-06-18 13:02:57: Backup destination cannot handle subvolumes and snapshots. Snapshots disabled.

(I haven’t yet tried installing libguestfs-tools, as I have no use for image backups at present.)
I don’t know if the BTRFS functionality would get presented to a Docker container - but from what you’ve written above, it looks like btrfs-tools would have to be installed anyway?

Thanks!

Hi, can you post a new package for 2.4.13 ?
Thanks. :wink:

Hi,
yes in the next few days, after my hollyday :grinning:

Thanks ! :+1:

ready :grinning:
https://github.com/josef109/spksrc/releases

Thank you ! :pray: