Native Synology Package

It seems the website is currently down?

It is likely you tried to access during the maintenance window. It should be available 7AM to 9PM EST.

Ah thank you. It works now :).

However, after adding the package source and going to “All” in the Package Center and hitting “Refresh”, UrBackup still doesn’t show up as an installable package.

Is it may be not compatible with DSM 5.1?

It is likely that it is not compatible with your particular model. It is hardware dependent (not DSM version dependent).

Yes, I just noticed that mostly only the x86 CPUs are supported. It’s a Marvell Kirkwood mv6282 2.0Ghz ARM (Marvell ARMADA 300) in my case (DS212+).

Yes unfortunately all the 16-bit memory devices are current unsupported. If the cross-compiling frameworks get updated, however, they will become available automatically so keep on eye on your package center.

I believe I’ve overcome the upstream issues that were preventing compilation on some of the non-Intel architectures. Please keep an eye on my syno webpage to see if your model is now supported. They should appear over the next few days.

Really nice work on this Synology port. Installed 88f6281 on a DS212j with next to no effort.

Thanks for the kind words; appreciated!

It’s a bit inconvenient, that the server (for looking up the package source URL) is not up 24h. It appears the old URL for the package source does not work anymore?

There were too many Asia based hack attempts through the synology package center ports (DDoS) URL.
The packages remain available for manual download and installation at the address posted in the thread.

Hello, is it possible to get version of UrBackup for model DS413 (architecture qoriq, CPU
Freescale QorIQ P1022).


The upstream cryptopp does not cross-compile gracefully for the PPC and I have not been successful in overriding the CFLAGS / CXXFLAGS. It may be the CPU does not have the instruction set needed for crypto++. Unfortunately these sorts of things take a fair amount of time and effort to research and based on the current level of interest it is not likely to happen any time soon.

Any chance for a version for armada300? (i.e. my DS212+)

It is my understanding that Synology treats the DS212 (88f6282) as it does the 88f6281 CPU. They refer to them both as 88f628x and only provide a single toolchain. You should be able to use the 88f6281 package posted.

I see, thx, I’ll try that :slight_smile:

Hm, I don’t know, I just tried it. Installation went without errors it seems and the package center says the server is running. However, when opening the Webinterface (on port 55414, via LAN) nothing happens. The browser states it’s connected, but it endlessly stays at “Connecting…”.

All links to subdomains are invalid.

Removed the link to this thread from the download page now.

A post was split to a new topic: Synology package