[SOLVED] WebUI image mount error with guestfs


#1

Running UrBackup server 2.1.19 on debian. Mounting via the web interface has worked in the past. This system has auto updates for the OS and UrBackup disabled.

When trying to mount an image via the web interface to restore a file I get this error:

2017-06-30 09:21:50: VHD-Parent: "/mnt/urbackup/SERVER/170628-2102_Image_C/Image_C_170628-2102.vhd"
2017-06-30 09:21:50: VHD-Parent: "/mnt/urbackup/SERVER/170522-0945_Image_C/Image_C_170522-0945.vhd"
2017-06-30 09:21:52: VHD-Parent: "/mnt/urbackup/SERVER/170628-2102_Image_C/Image_C_170628-2102.vhd"
2017-06-30 09:21:52: VHD-Parent: "/mnt/urbackup/SERVER/170522-0945_Image_C/Image_C_170522-0945.vhd"
Loading FUSE kernel module…
Starting VHD background process…
Waiting for background process to become available…
Mounting…
libguestfs: error: /usr/bin/supermin exited with error status 1.
To see full error messages you may need to enable debugging.
Do:
export LIBGUESTFS_DEBUG=1 LIBGUESTFS_TRACE=1
and run the command again. For further information, read:
http://libguestfs.org/guestfs-faq.1.html#debugging-libguestfs
You can also run ‘libguestfs-test-tool’ and post the complete output
into a bug report or message to the libguestfs mailing list.
Mounting failed.
UrBackup mount process returned non-zero return code

Mounting via the command line works fine.


Can't mount a Windows image backup
#2

Same as here? https://bugs.launchpad.net/fuel/+bug/1467579


#3

My error was a little different than what was in that thread, but that thread led me to the solution.

For some reason I need to change the permissions on my /boot/vmlinuz* files. I did that and it works again.

Good find! Thank you.


#4

Same here. Running urbackup 2.1.19 on Ubuntu 16.04.
I ran the libquestfs-test-tool (as user urbackup) and it resulted in the follwing error:

cp: cannot open ‘/boot/vmlinuz-4.4.0-87-generic’ for reading: Permission denied
supermin: cp -p ‘/boot/vmlinuz-4.4.0-87-generic’ ‘/var/tmp/.guestfs-111/appliance.d.hd81iubc/kernel’: command failed, see earlier errors

Changed the rights to 604 and image mounting is working again.

Now only create a solution which survives a kernel upgrade.

Thanx


#5

Open a bug at your distribution bug tracker for libguestfs-tools ?