Restore option isn't available via the webinterface


#21

Try running

urbackupsrv repair-database

on the server. Maybe that forces a rebuild? Service should be stopped before running this I guess.


#22

Check the my last post, it’s not related to the database rebuild, but to the client version.
It works for Ubuntu 12.04 but not for 14 or 16


#23

Hi there,

I can confirm this.

No problem from windows clients, but I can’t restore files to linux webserver (centos 7.2 / internet mode with nat in front).
Server 2.1.19 / Clients 2.1.15

urbackupclientctl is fully functional, I can browse, restore, etc… but not from Web GUI.

Hope it will change soon, cause it’s an absolutly needed feature :slight_smile:

Edit: ok, it needs a server reboot… could be updated in next version ?


#24

Well, I was wrong… It doesn’t work in some case…

Client:
Centos 7.3.1611 / kernel 3.10.0-327.13.1
urBackup 2.1.15
RESTORE=server-confirms in /etc/sysconfig/urbackupclient (Service restarted after changes but not server)
Nothing wrong in /var/log/urbackupclient during backups

Server:
Centos 7.3.1611
urBackup 2.1.19

I only do file backups, complete & incrementals, I’ve restarted server many times, test urbackupclt repair-database, but nothing seems wrong.

At least, how can I help you in debugging this ?


#25

Has anything been figured out with this? I just setup a test install of both the server and client on two debian jessie systems and Im logged in the web gui as admin and i do not see any restore buttons in the gui either for a client system that is indeed online. only gives me a download file option. I have indeed added RESTORE=“server-confirms” to the /etc/default/urbackupclient. I couldnt locate a service to restart on the client, so even went as far as fully rebooting the system since its just a test. Restarted the normal urbackup service on the server. No difference.


#26

I am guessing the answer is no?


#27

Nope, looks like something that is related to spec. linux versions.
I have a server with an older Ubuntu version where it’s working like it should…


#28

Debian 8.7 (jessie) client here, can confirm server doesn’t have a button to restore to client.

CentOS 6.8 has a restore button.

Something about newer OS versions?


#29

Very strange after several week I get this “restore to client” for several servers (Ubuntu 14.04).
All these sever have been missing this button at the time that I opened this topic.
My latest server with Ubuntu 16.04 has this button too. So I think it’s not an OS problem and maybe something else…


#30

Is this fully working yet for everyone? I really want to give urbackup a try, but without a working web interface, its not as useful to me. Is there a list of supported OS versions that its expected to work on in a stable fashion?


#31

The web interface os working great on Ubuntu, it’s just the one-click restore isn’t available for all client machines and I don’t know why :frowning:
It worked for some client machines after a while.


#32

Is there any update on this, i have the same issue, 2 servers on CentOS Linux release 7.4.1708 (Core) and it only shows the List option - all my other servers work fine without any issues.


#33

Hi there,

I’m with the same problem; all of the Linux clients (mixed: Ubuntu, Debian, CentOS, Oracle Linux) doesn’t show the restore button in the server web interface; all of the Microsoft Windows clients shows and restore the files fine.

Server version: 2.2.11
Client version (all): 2.2.5

All the linux clients are set up with the “RESTORE=server-confirms” option, but none shows up. Already restart the clients; did not restart the server yet (still have backups running).

Any light over this issue?

Thank you very much.


#34

Had the same issue here running the (headless) client on debian jessy and the server on ubuntu.
Adding the server-confirms statement and restarting both server & client did the trick for me.

Worked flawlessly after that :slight_smile:


#35

Hi Jejamin,

I already rebooted both, server (after all the running backups end) and some of the clients (that I’ve updated yesterday). Still not every client are showing the restore button (just the Microsoft Windows ones). In total, are more than 30 clients configured.

The server is running over an Ubuntu 16.04 with btrfs for backup storage and using UrBackup version 2.2.11. All clients are using the version 2.2.5, except one (legacy, using 1.4.11). All of the clients are headless and all of the Linux clients are set with the “RESTORE=server-confirms” (some screens of server’s web interface are attached).

EDIT: I’ve implemented this server this week; I’ll let it run this weekend and check it again on monday, to see if it is some data base index or something like it that is probably running.

Thank you very much; best regards.


#36

Just to make sure, this is what /etc/default/urbackupclient contains (as well as other config ofc)?

# Valid settings:
#
# "client-confirms": If you have the GUI component the currently active user
#                    will need to confirm restores from the web interface.
#                    If you have no GUI component this will cause restores
#                    from the server web interface to not work
# "server-confirms": The server will ask the user starting the restore on
#                    the web interface for confirmation
# "disabled":        Restores via web interface are disabled.
#                    Restores via urbackupclientctl still work
#
RESTORE="server-confirms"

#37

Hi Jejanim,

I’m pretty sure that all Linux servers are set like this. I’ve installed the client, wait for the first backup to run and then change the restore option to “RESTORE=server-confirms”. After that, I’ve restarted the server.

EDIT: just adding, in the Microsoft Windows servers I didn’t change a thing and they work fine.

I’m out of work now, but I can confirm to you on monday. The only thing that differs that I can see now are the quotes; I’m sure that I followed the same as the default setting, “RESTORE=disabled”, without the quotes. Does this matters?

Thank you very much.


#38

I don’t know but I suggest giving it a try.
After all, that’s what the comments suggest (“server-confirms” in quotes).


#39

What does ps -Af | grep urbackupclient say on one of those clients?


#40

Hi Jejanim,

I’ve tried, but nothing changed. When I arrived at work today, it still was without the “Restore” button; I’ve changed the setting to RESTORE=“server-confirms” (with quotes) and restarted the client, nothing changed. So, after that, without any backup running, I’ve restarted the service “urbackupsrv” in the server; after that, most of the clients are now showing the restore button. I said “most” because some clients are still not showing the button, as the images show bellow (just taken - both Linux servers). Couldn’t get the logic behind this, but I think it’s an indexing of somekind behind.

Working server:

Server without the “Restore” button:

Thank you very much. Best regards.