Restore option isn't available via the webinterface


#1

Hi,
I enabled the restore inside “/etc/default/urbackupclient” optie with

RESTORE=server-confirms

According the information

The server will ask the user starting the restore on the web interface for confirmation

I would accept that I’m able to restore files or directories from the server webinterface. But there is not a single option to do that. Do I need to restart something (what is the restart command on Ubuntu?)

Thanks


#2

No one here using urBackup on Linux?
I’m wondering why no one has asked this before (there are similar questions, but they have no answer too).

Thanks to everyone who has some hint to find some information.


#3

From the webUI, you can browse “Backups” and see the file/image backups. For file backups, just click on it till you find the file/folder you want to restore, and click “Restore” button; for image backups, you can click “mount image” and then browse to the file/folder, you may download the file/folder in the image, but cannot directly restore it from the webui

Make SURE your client is active otherwise “restore” button will not show up (which makes sense).


#4

Hi,

thanks for the information, this is what I also find in the documentation. Are you talking about the webUI from the server or from the client? The server webUI doesn’t show that option (see screenshot)

If this option is available only in the client webUI than please check my other question regarding my problem with the client webUI


#5

I am talking about the webUI on the server side. Client does not have a webUI.
Make sure:

  1. your client is powered on (otherwise the restore button will not show);
  2. make sure you have done backups successfully (restore will not be available if backup is not completed)

#6

Hi,

thanks for the screens. At least one thing is clear: There is NO webUI for the client :slight_smile:

Backups are working and the client(s) are web server, so they are always online.
It should work like you describe, but there is no restore button. Do I need to restart the client to get the setting “RESTORE=server-confirms” active (and what is the command for doing this) or do I need another settings.

Everything is fine except the restore function is missing. The server created full and incremental backup several times.


#7

Just to be sure that my settings are right:
On the the settings tab I need to enter the Server URL…

URL to which the client will browse if a user selects “Access/restore backups”. For example “http://backups.company.com:55414/”. Default: “” (If empty “Access/restore backups” will not be available on the clients.)

This is the same address as the URL for the webinterface right?


#8

I would suggest you do not change any default settings. Just do a fresh installation and then conduct several backups. Then use http://IP:55414 to access the server, you should see all above screen snapshots.


#9

There is no difference if I use the server’s IP address or the hostname, the restore buttons doesn’t show up. Check this screens anything else is working.



#10

Which version of server/client are you using and for how long? We had a “bug” where we used different binary because uroni switched folder for binaries and didn’t delete the old ones. Check web console, does it show any errors?

Another thing to check is whether you are logged in with admin account or something else?


#11

I’m using urBackup (2.1.19) since a week, installed the server on Ubuntu using apt-get. The client I’ve installed is downloaded from my backup server.

I’m logged in as the admin.


#12

Hmmm, I’m yet to upgrade to 2.1.19 so not sure if it’s related to version. Web console doesn’t show errors, right?


#13

Nope, there are no errors. Everything went smooth, just the missing restore buttons


#14

Is there no one with a similar issue? The backup function works great for almost two weeks, but there is no restore button for any of the 3 server I backup with UrBackup.
Is there maybe a missing configuration which is not documented?
Thanks.


#15

I never even noticed until I read this thread but I only have a “restore folder to client” button for some of my clients and not others.
This seems to affect a mixture of Linux, Windows and OS X clients.

I am using Server 2.1.18


#16

This was the problem, I forgot to add quotes before and after the option server-confirms. After I added the quotes and restarted the server, the server did some re-index and voila I have the “restore to client” button in my backups list :slight_smile:


#17

Hmm, that shouldn’t make a difference. If anyone confirms this problem I’ll have a look at it.


#18

I only have a “restore folder to client” button for some of my clients and not others.
This seems to affect a mixture of Linux, Windows and OS X clients.

I am using Server 2.1.18


#19

I write only code for JS and PHP and strings need to have quotes.
There are other options with a string value and they have quotes too.
Anyway I’m glad that it’s working now. Great backup system, easy to use and has all the functions you need!


#20

I installed the client now for other servers and the restore option isn’t available for them.
It looks like that the database isn’t updated after the new client with the setting for
RESTORE=server-confirms
option is changed.
Last time I did a restart for the server and than database update has been started too. After the database was updated the restore option for the existing clients was available. Is there a way to force the rebuild of the database? @uroni looks like you was right about the quotes :slight_smile:

Edit:
I’ve noticed that only one client shows that option. That client is installed on a different version of Ubuntu 12.04 and all others are installed on a newer version 14.04. Now I’m not sure if the restore option was available on that Ubuntu 12.04 server before the database rebuild.