Restore on Windows Client not Working

Hello,
i have a Problem with the urbackup windows client.

Backing up and restoring over the webinterface works fine, but when i want to restore something on a client machine by selecting “access backup” from the right-click menu, it shows me an error “Error Connecting to the Server” (As shown in the Screenshots).

Starting a Restore from the Webinterface, or a Backup from the Client works fine, since the issue is reproducible on all 3 clients i suspect a setting on the serverside, but don’t know which.

How can i Debug this?

Unbenannt Unbenannt2

Urbackup Version: 4.10 on the Client, 4.11 on the Server
Client is a Windows 10 Pro, The Server is running in a Freebsd Jail.

What ports are explicitly open on the server and client?

Client requires:

Port Usage Protocol
35621 Sending files during file backups (file server) TCP
35622 UDP broadcasts for discovery UDP
35623 Commands and image backups TCP

There is no firewall on the server and the client has the ports opened.

➜  ~ nmap -p 55413,55414,55415 192.168.100.3      
Starting Nmap 7.80 ( https://nmap.org ) at 2020-02-27 09:39 CET
Nmap scan report for 192.168.100.3
Host is up (0.0014s latency).

PORT      STATE SERVICE
55413/tcp open  unknown
55414/tcp open  unknown
55415/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 0.04 seconds
➜  ~ nmap -p 35621,35623 192.168.100.50 
Starting Nmap 7.80 ( https://nmap.org ) at 2020-02-27 09:39 CET
Nmap scan report for DESKTOP-18G1LST.sphairon.box (192.168.100.50)
Host is up (0.060s latency).

PORT      STATE SERVICE
35621/tcp open  unknown
35623/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 0.12 seconds

Also, when i start the server in Debug mode, i don’t see anything regarding this access in the log (i see the backups etc, but not a request regarding the “access backups”, so a network problem still seems plausible)

+1 I have the exact same problem , windows client , right click restore option does not work says : cant connect to server , backing up works , restoring from webUI works . Anyone solved this issue ? I have no idea where to start with this .

I have verified open ports on server and client , and i have added extra exceptions for all programs in windows ports for 35621-35623 .

My client settings are controller from the server side.

urbackup Server is installed on virtual ubuntu 20.04 server edition on a xenserver.

Problem is replicable on multiple clients running Win7 / Win 10 .

Urbackup server is only in local network . internet mode is not enabled.

Im thankfull for any insight or location where i can gather more data why this happens as this feature is very usefull and its non functioning is relatively big problem.
Im also keen on actively engaging in this post to get to the root of this bug.

Sorry you are having issues. To solve the problem the server and client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client and server to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting

Thanks!

1 Like

I have enabled debug on windows 7 client


I have enabled debug on urbackup ubuntu server and restarted the server

I have checked if server and client is connected again.

I have tried to use the windows function for restore file.and another file.
Weird thing , the tex file i tried to restore it threw the error as described in the first post . The .msi installation file i t ried to restore threw no error but instead just launched as if i double clicked it ? (i have tried this twice).

The files names i tried:
Standard Ansicht Einstellung.txt
Webex-new.msi

Both located under: C:\Daten_PC2

I have 1 working full file backup of these files and a couple incremental backups :


debug.log (23.5 KB) windows log
urbackup.log (11.5 KB) server log

If you need any additional information or actions i need to take please dont hesitate to tell me.

Thank you for your feedback

It seems you didn’t set the server url in the global server settings. Set that correctly and it might work.

(When the users clients “access backups” it opens the browser to your server which displays the file versions)

1 Like

Thank you i tought that setting was only for internet access , now it works with the other files but the msi , file does not open the website with its versions rather it still executes the local msi file as if i double clicked it with left mouse button .

any ideas regarding the MSI file ?

Can reproduce. Will look into it. Till then I guess go via tray icon → access backups as work-around…

thank you for the response and help .