Not doing full backup because of internet connection

Solution: Do a FULL backup again and the problem will be solved. It seems was an error in the previous incremental.

Everything was working fine, I can see the client connected to the server but I’m not able to do a backup. I have all the options activated to do backup over internet but neither this way is doing a backup. This es the log: Connecting for filelist…
08/01/16 10:15 DEBUG Waiting for filelist
08/01/16 10:15 WARNING Restarting shadow copy of C:\ because it was started by this server
08/01/16 10:15 INFO Scanning for changed hard links on volume of “test”…
08/01/16 10:15 INFO Indexing of “test” done. 1 filesystem lookups 1 db lookups and 0 db updates
08/01/16 10:15 DEBUG Doing backup with hashed transfer…
08/01/16 10:15 INFO Loading file list…
08/01/16 10:15 DEBUG Starting incremental backup…
08/01/16 10:15 INFO Calculating file tree differences…
08/01/16 10:15 ERROR Error while calculating tree diff. Not doing full backup because of internet connection.
08/01/16 10:16 ERROR Backup had an early error. Deleting partial backup.
08/01/16 10:16 WARNING Exponential backoff: Waiting at least 1h 20m before next file backup

1 Like

I’ve also suddenly started getting a lot of “Error while calculating tree diff. Not doing full backup because of internet connection.”
It’s happening with various versions of Windows, Linux and OS X clients.
I told all clients that were online to perform a full backup and it has fixed some but a lot of clients have since disconnected before the full backup completed. I’m now going to have to check the log for each client, over 100, to see which are backing up and which are failing.

I did upgrade to Server 2.0.33 at the weekend. Could this be the cause?
Any help will be appreciated.


There is probably more information in the server log file. See here for more information about the server log file: Having problems with UrBackup? Please read before posting

Thanks. I’ll take a look.

Thanks for the log file. It does not log more info, but that rules all other possible errors, so it must be unable to open the clientlist_b_{backupid}.ub files in /var/urbackup of the previous file backup. Apart from them being deleted somehow this could e.g. happen if you use an outdated database backup (it cleans up old clientlist_b_ files).

Edit: Actually. They seem to be present, but it cannot open them. Maybe they have the wrong permissions/owner?

Ok that makes sense.
A few weeks ago I cloned the freenas jail, using the warden, just in case.
When I decided to upgrade the server on Saturday night I thought it would be clever to upgrade the clone so as to keep the working installation intact. I first backed up the database, or so I thought. I did in fact back up the urbackup folder in the backup storage.
I then compiled and fired up the new server in the clone jail. It seemed fine until I realised that most of the clients were missing. I quickly shut down the jail.
Upgraded the original jail and fired it up, crossing my fingers.
The upgraded server seemed to be fine until I noticed this issue in the logs.

I hope that all makes sense.

The question now is how do I get all the affected clients to get past this?
I can tell them all to do a full backup but they are not all online 24/7. Is there a way to get them to begin a full backup the next time they connect to the server?

Many thanks,

Here’s a partial directory listing;
-rwxr-x— 1 urbackup urbackup 0 Aug 27 22:28 clientlist_b_1.ub
-rwxr-x— 1 root urbackup 68787 Aug 27 22:28 clientlist_b_10080.ub
-rwxr-x— 1 root urbackup 29420 Aug 27 22:28 clientlist_b_10226.ub
-rwxr-x— 1 root urbackup 16393714 Aug 27 22:28 clientlist_b_10393.ub
-rwxr-x— 1 urbackup urbackup 438 Aug 27 22:28 clientlist_b_11.ub
-rwxr-x— 1 root urbackup 26740 Aug 27 22:28 clientlist_b_11126.ub
-rwxr-x— 1 root urbackup 768685 Aug 27 22:28 clientlist_b_11197.ub
-rwxr-x— 1 root urbackup 361582 Aug 27 22:28 clientlist_b_11281.ub
-rwxr-x— 1 root urbackup 312260 Aug 27 22:28 clientlist_b_11452.ub

It seems I messed up the permissions alright.
I take it they should all belong to urbackup?
I’ll wait for confirmation before changing anything.

I would just run it as root to avoid all those issues. It is the only thing in the jail and has access to all the critical data anyways. See the instructions:

Otherwise chown -R urbackup:urbackup /usr/local/var/urbackup.

Thanks for the prompt help.
I’ve just chown urbackup *.ub which seems to have done the trick, fingers crossed. (EDIT: It worked!)
I’m away for a week tomorrow, so no time to look at running everything as root.

I’ll grab some CBT licences in the morning to help out.

This really is great software and fantastic support.

Big thanks,

Same here, Full File backup resolved this error on one of my clients that were failing Incremental backups.