'No paths to backup configured' for Windows Clients

I am getting this message on a fair number of clients. When I changed the logs level to debug, it does appear to be connected to my internet server based on the logs but the settings are not getting pulled from the server and applied. What is the best way to troubleshoot this issue?

I recently found a bug where it doesn’t send updated group settings to (online) clients. A work-around is to save the global settings (without changing anything).

Otherwise see:

I’ve been pulling my hair out on that one all day thinking it was something with the communication. That did the trick for the device I have access to. I will report tomorrow once the others hopefully check in and update correctly.

This worked for my test client. It appears though that a reinstall may be necessary. Anything else I can try before going down that road?

I’m continuing to have this issue, currently, 48 out of 145 clients. I’ve tried saving settings and that hasn’t worked for these ones. Anything else I can try?

Hi @uroni,

I am facing the issue also that group settings are not sent to online clients. For this also your suggested workaroung does not work. I have tested Linux and Windows clients, both suffer from the same wrong behavior.

Bye

By the way, as an addition to my post, this seems to happen only to clients that already have some local configuration values. Here the checkbox “Separate settings for this clients” seems to not work correctly. Even if it is deactivated the group settings are not pushed.

Bye

So far in my case, change a setting, save the changes, change it back, & save again has seemed to “unstick” clients I’ve had get stuck giving this error.

I’ve tried that. I’ve tried moving client to another group and back. I’ve even tried reinstalling the client. The only thing I have not tried is removing it from the server and recreating it. Hoping for a fix before I have to do that though.

Probably a silly question but when reinstalling did you use the “download client for windows” option from the UrBackup status page & select the correct client?

Not quite the “only” thing not tried, at this stage there’s still editing C:\Program Files\UrBackup\data\settings.cfg directly on the client & entering suitable values for default_dirs= & default_dirs_def= using notepad as administrator, then restarting the service there. I don’t think that’s recommended, but I might try it before the nuclear option. That’s the file & config keys it appears are failing to update. Use those keys from a working .cfg as an example.

You’d have to see if that behaved as expected after doing so & allowing the first backup, & if changes made on the server propagated to the client properly afterward.

See my first post w.r.t. client debug log that would be required to find the issue.

W.r.t. server please make sure that if you browse to the (greyed out) client settings, that it displays the correct value there – otherwise it is a server issue.

It is not necessary to edit the settings.cfg file manually. Instead one can simply activate “Separate options for this client”, set the corresponding option, save, remove “Separate options for this client” and save again. In my case then the correct value is pushed to the client. But this most likely causes the value to be client specific and breaks the “inheritance” from the group. So far the only way it worked for me to transfer new value to client.

Probably a silly question but when reinstalling did you use the “download client for windows” option from the UrBackup status page & select the correct client?

This is not an option for us since clients are so disconnected.
Our deployment methodology is:

  • Install UrBackup MSI on client
  • Register new client via API
  • Retrieve client auth key via API
  • Configure client with information from server (extra args file and UrBackupClient_cmd.exe)

I recently found a bug where it doesn’t send updated group settings to (online) clients. A work-around is to save the global settings (without changing anything).

I uploaded my server logs via report problem and also sent client logs via email.

Could you go into specifics here? Note that configuring “paths to backup” is separate from setting it via “default_dirs”.

I can send you a sample but extra args config has the enable internet mode, internet mode only and thing like the secret key.

I am experiencing the same issue with the 2.4.10 client but less frequently. Based on that, I can’t say for certain version has any impact.

I found that stopping the client side service, removing the lines client_set_settings and client_set_settings_time then restarting the service seems to fix the issue after 5 minutes or so.

Where do you remove those lines from? A specific file? Experiencing this on a client now.

I started to notice that just restarting the service while logged on would coincidentally work. That got me looking at out content filter which ended up being the root cause. Since our clients went out to backup over the internet, it was being filtered at the firewall. Fixing that allowed the clients to communicate unattended.