Mounting image failed. Please see server log file for details

But server log does not include any details.


Can give more details about your environment? Is this a linux or windows based server? What version of urbackup?

Have you tried running the server in debug mode and capturing the log to see why the mount fails?

i have the same problem

with 2.2.27 work correctly but after upgrade to 2.2.28 not work

mi environment is ubuntu 16.04.4 lts


Server runs on Ubuntu 17.10.
urbackup version 2.2.8.

Did not try debug mode.

Ran server in debug mode, attempted to mount an image backup, mount failed but nothing was mentioned in the logs.

What else should I do?

For information, i have the same problem but no solution yet (post Mounting image failed)

It used to work in a previous version.
Is this being taken care of? No official word.

Add me to the list. Have only tried server v.2.8.8/Linux Ubuntu 16.04.3, Ext4 root/btrfs storage, latest released kernel.

Changed logging to debug, restarted, but nothing new listed in log file.

Should work with 2.2.9 now

Thanks for the quick reply and update.

I now get more information:

Mounting image failed. Please see server log file for details.
Guestmount… libguestfs: error: /usr/bin/supermin exited with error status 1. To see full error messages you may need to enable debugging. Do: export LIBGUESTFS_DEBUG=1 LIBGUESTFS_TRACE=1 and run the command again. For further information, read: You can also run 'libguestfs-test-tool' and post the complete output into a bug report or message to the libguestfs mailing list.

Server log is set to debug and includes very much similar to above message received in UrBack Web UI…

Can you post the output of ls -lh /boot?

Afterwards try if running sudo chmod 0644 /boot/vmlinuz* fixes the problem.

Note that I cannot reproduce the problem with the same distribution. So maybe you really need run libguestfs-test-tool.

/boot dir info:

total 151M
-rw-r–r-- 1 root root 1.2M Jan 19 08:06 abi-4.4.0-112-generic
-rw-r–r-- 1 root root 1.2M Feb 12 19:57 abi-4.4.0-116-generic
-rw-r–r-- 1 root root 1.2M Apr 2 14:05 abi-4.4.0-119-generic
-rw-r–r-- 1 root root 187K Jan 19 08:06 config-4.4.0-112-generic
-rw-r–r-- 1 root root 187K Feb 12 19:57 config-4.4.0-116-generic
-rw-r–r-- 1 root root 187K Apr 2 14:05 config-4.4.0-119-generic
drwxr-xr-x 5 root root 4.0K Apr 4 15:12 grub
-rw-r–r-- 1 root root 39M Mar 1 08:10 initrd.img-4.4.0-112-generic
-rw-r–r-- 1 root root 39M Apr 4 07:06 initrd.img-4.4.0-116-generic
-rw-r–r-- 1 root root 39M Apr 4 15:12 initrd.img-4.4.0-119-generic
-rw-r–r-- 1 root root 179K Jan 28 2016 memtest86+.bin
-rw-r–r-- 1 root root 181K Jan 28 2016 memtest86+.elf
-rw-r–r-- 1 root root 181K Jan 28 2016 memtest86+_multiboot.bin
-rw-r–r-- 1 root root 2.7K Feb 12 19:57 retpoline-4.4.0-116-generic
-rw-r–r-- 1 root root 2.7K Apr 2 14:05 retpoline-4.4.0-119-generic
-rw------- 1 root root 3.8M Jan 19 08:06
-rw------- 1 root root 3.8M Feb 12 19:57
-rw------- 1 root root 3.8M Apr 2 14:05
-rwxr–r-- 1 root root 6.8M Jan 19 08:06 vmlinuz-4.4.0-112-generic
-rwxr–r-- 1 root root 6.9M Feb 12 19:57 vmlinuz-4.4.0-116-generic
-rwxr–r-- 1 root root 6.9M Apr 2 14:05 vmlinuz-4.4.0-119-generic

changed files to 644 from 744 and same error message.
Ran libguestfs-test-tool which ended with:

===== TEST FINISHED OK =====

Cancel that!
At least for now. I had not tried mounting an image after running libguestfs-test-tool.

Also works after reboot.

Thank you very much, indeed.

And… Back to not working. Same error as yesterday.

What kernel version are you running? I have had similar issues where debug mode says mount test is ok (that just means it found guestfs tools installed) but it won’t actually mount the images. If you add the debug environment variables for guestfs tools if should give you some errors pointing to supermin. UrBackup basically mounts the backup image in a supermin jail for system protection. On my systems, if they are running v4.13 kernel, the mainline kernel breaks supermin5 that liguestfs-tools uses.

If you download and compile the newest version of supermin5 and then re-install liguestfs-tools that may get everything working for you again.

This setup is running kernel version Linux 4.4.0 which, I believe, is the latest released to this v.16.04.3 ubuntu. I am planning on upgrading the 18.04 as soon as released. The thing is, when it worked for the first (and, so far, last time) I received a list of files and I even rebooted and could bring up a list of files after mounting the image via the web interface. When I attempted to mount the image the next day (system had not rebooted since successful testing the previous day), mounting failed.

I did not attempt to access any of the listed files. I was only testing by mounting an image.

In order to debug this I had to capture the exact command that urbackupsrv runs when it guestmounts an image.

I just continually ran a ‘ps’ while mounting selecting an image in the web interface to mount. Once I had the guestmount command, I then set the guestmount debug environment variables “export LIBGUESTFS_DEBUG=1 LIBGUESTFS_TRACE=1” and ran the same command the web interface was trying to run.

That’s what led me to discover the error in supermin which ultimately led me to the patch that fixed supermin for newer kernels.

You could attempt this same process to see if yields any results for why its not mounting.

Server version 2.2.11
Ubuntu 17.10 kernel 4.14.0

Edit: Upgraded kernel to 4.16.3, same result.

Have you tried what I wrote here:

Using the mount helper as root always fixes this problem for me but after a couple of days/updates/restarts (I don’t really know what breaks it) it stops working again.

Would be good to find out why it works after mounting as root so I could at least have a script run at startup to make sure that it works automatically.

1 Like

Your solution works!

P.S. No need to mount as urbackup, mounting as root is sufficient.