Mount image disappeared

Installed 2.1.18 on a Debian server, using client 2.1.14 (on windows 7), did both full and incremental image backup. but couldn’t find the “mount” button to mount image

Same here after updating to 2.1.18.

Same problem here after upgrading from 2.0.38 to 2.1.18 on a Debian/BTRFS server.

Although the mount button does show up on a Debian/EXT4 server that was upgraded from 2.0.38 to 2.1.18…

I just checked another Debian/BTRFS 2.0.38 to 2.1.18 server and the button also shows up, so it doesn’t seem to be BTRFS/EXT4/etc related. However, on the server where the button does not show up, was an older server which was upgraded several times from 2.0.13 onward. But on the systems that started out at 2.0.38 and then upgraded to 2.1.18, the button shows up.

I also noticed when upgrading a new 2.0.38 to 2.1.18 server, I had to run apt-get install -f to complete the install of 2.1.18. This installed a bunch of other packages. On the older server which started out as 2.0.13, I didn’t have to run apt-get install -f to complete update, so I suspect the packages needed for the mount button to work aren’t installed…

My case is a new install on Debian 8. I did use apt-get -f install to complete the installation after dpkg. However I noticed that before 2.1.18, it will install ~143MB packages, but with 2.1.18, it only installed 4~5MB.

Upgrading 2.0.38 to 2.1.19 on Debian has the same issue. Has anyone found a way to get the mount button / required packages installed?

Did a new test: Fresh installation: Server — Debian 8.7.1; Client —Windows 7 x64 and installed 2.1.14 no tray.
Image Backup is successful. But cannot mount image. see the snapshot below:

Could you further investiate by running urbackup_mount_helper test ?

urbackup_mount_helper test
TEST FAILED: guestmount is missing (libguestfs-tools)

apt-get install -y libguestfs-tools

urbackup_mount_helper test

systemctl restart urbackupsrv.service


confirmed the same information:
showed TEST FAILED: guestmount is missing (libguestfs-tools)

However, after apt-get install libgestfs-tools, system installed 127MB files, but still no mount image button.
Update: after a reboot of the server, the mount image button showed up!

Still no luck here:

[root@~]# uname -a
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[root@~]# yum list installed libguestfs-tools
Installed Packages
libguestfs-tools.noarch                         1:1.32.7-3.el7.centos.2                         @updates

[root@~]# urbackup_mount_helper test

Same after reboot, no mount image button.

After setting sticky bit:
# chmod 6755 /usr/bin/urbackup_mount_helper

# systemctl restart urbackupsrv.service

Mount button appeared

…Though I don’t know if this is good solution, as setting sticky bits is undesirable…

Ok, this is on CentOS 7 with the OpenSUSE package? @Alexander_Rebrov

It seems install via dpkg does not install recommended packages. There is no way to fix this other than put it back into the hard dependencies which I do not want to do. So for now on debian libguestfs-tools must be installed manually for the image mounting to work.

Another option is to use the OpenSUSE download for Debian:

Please, tell me what rights was set on file /usr/bin/urbackup_mount_helper before you changed its?

rwxr-xr-x urbackup:urbackup
There was no sticky bit

napisala je: i stand corrected, it was
rwxr-xr-x root:root

Are you sure? File /usr/bin/urbackup_mount_helper must be 4755 root:root permissions

just install a new server at sl-linux 7.3 with urbackup-server- rpm.
and the permission of /usr/bin/urbackup_mount_helper is 755.

[root@backup ~]# rpm -qval urbackup-server | grep helper
-rwxr-xr-x 1 root root 100248 Feb 26 03:03 /usr/bin/urbackup_mount_helper
-rwsr-xr-x 1 root root 112712 Feb 26 03:03 /usr/bin/urbackup_snapshot_helper

download opensuse rpm and the permission is fine. so it seems only rhel rpm is broken.

I was update urbackup server to new version urbackup-server- on OpenSuse Build Service. In this version the permission of /usr/bin/urbackup_mount_helper shoud be 4755 root:root. Please test this.

unfortunately it seems meaningless now. please check my other post Mount image is not working under RHEL 7.3

so in RHEL 7.3 you must conquer two part:

  1. libvirt don’t want suid (should we run urbackup as root?)
  2. libguestfs don’t want ntfs (need to re-package libguestfs)

so I don’t know what’s the correct way to package urbackup rpm under RHEL…