Macos 10.14 unable to uninstall


#1

Here’s the steps on the machine:

  1. Time Machine backup on old machine
  2. Restore to new machine, Urbackup config moved but still using the same settings as old machine (New o/s Mojave with permissions)
  3. Trying to uninstall with urbackup_uninstall script in package (so I can create a new backup with new name leaving old backup in place as old machine still being used).
  4. Get error
Last login: Tue Dec  4 08:28:32 on ttys000
Jennas-MacBook-Air-2018:~ jenna$ /Applications/UrBackup\ Client.app/Contents/MacOS/sbin/urbackup_uninstall ; exit;
trap finish EXIT
/bin/launchctl list org.urbackup.client.backend
+ killall urbackupclientgui
+ '/Applications/UrBackup Client.app/Contents/MacOS/urbackupclientgui' remove_login_item
+ pkgutil --forget org.urbackup.client.service
No receipt for 'org.urbackup.client.service' found at '/'.
+ finish
+ [[ '' == \t\r\u\e ]]
+ osascript -e 'display notification "Failed to uninstall UrBackup" with title "UrBackup"'
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

Tried running from command-line with sudo, same issue. FDA (Full Disk Access) in Mojave is enabled.


#2

Looking at the uninstall script it looks like these commands now fail with Mojave:

   pkgutil --forget org.urbackup.client.service
   pkgutil --forget org.urbackup.client

Steps to manually force-remove the Urbackup Client.app

  1. Rename “Urbackup Client.app” to something else.
  2. open terminal window:

sudo rm -fv “/Library/LaunchAgents/org.urbackup.client.plist”
sudo rm -fv “/Library/LaunchDaemons/org.urbackup.client.plist”

  1. Restart the Mac because you can’t Force close Urbackup using Activity Monitor (it relaunches)
  2. Delete the renamed “Urbackup Client.app” file.

Will have to wait for the uninstall script to be updated to support Mojave.


#4

I do this with the following:

sudo launchctl unload /Library/LaunchDaemons/org.urbackup.client.plist

…in conjunction with a sudo rm -rf to get rid of the application itself, this seems to prevent it from respawning… :slight_smile:

To be honest, the uninstall script never worked for me on 10.13 either…


Possible macos 10.14 issues - access denied causes backup to fail