Local clients can't connect to server, internet clients work fine

Hello everyone. I have a urbackup server (Lubuntu 20.04.2 LTS) that has been working perfectly fine for almost two years. It has about 10 clients that use it in internet mode, and 10 more locally, all windows machines.
Now, since about a month ago for some reason the local clients are not connecting to the server. Internet clients work just fine, and even the LAN clients if I turn on internet mode, they work as well.
I can ping the clients from the server, and viceversa. I have tried disabling the firewall on the clients (but given that internet mode works on all clients, I doubted it would fix anything) and no change.
Server version is 2.5.25 and clients are mostly 2.2.6 but some have 2.5.19, neither work locally.
The clients don’t show any error and just act as if the server didn’t exist. There is a second urbackup server (windows based) that works just fine locally with all clients. This second server is as old as the one with the problem, and all clients used to backup up to both without any issues (serveridents are correctly set up).
Server and local clients are in the same subnet. I don’t know what I’m missing. There is no documented change on my end on the network, server or the entirety of the clients.
This is a small business, with a dead simple network, as in modem, router, switch (unmanaged) and nothing else.
Any idea what else to check?

Is this on a Hyper-V?
Then probably this will help: UDP Discovery Stopped Working



I can’t believe I didn’t say the server was a VM on Hyper-V. I’ll check that link right now. Thank you.

You magnificent b*stard. Dug around a little and sure enough, a windows update made UDP not work with Hyper-V. Removed a few until suddenly it started working again and all clients are now online.
It would be nice to be able to be up to date and have a normal working VM, but well, nothing I can do about it.
Problem solved.

I would install the windows updates and run
ethtool -K eth0 tx off
inside the urbackup VM either manually after each reboot, as I do (because I’m hoping Microsoft will fix that. Will they?) or with some sort of init-script.

I’m using that solution since @maropr posted it in @dimoochka s thread and had no problems so far.

@lunacom’s suggestion on that thread of adding the following to the server’s netplan also resolved the issue for me, without having to revert Windows updates on the hyper-v host:

tcp-segmentation-offload: false
tcp6-segmentation-offload: false
receive-checksum-offload: false
transmit-checksum-offload: false
generic-segmentation-offload: false
generic-receive-offload: false
large-receive-offload: false

For what its worth, I had some windows clients that were working fine and suddenly stopped being able to connect to the backup server on the lan. Not all windows clients stopped but the ones that did, some update or something had changed the network type from private to public. As soon as I changed the network type back to private, they re-connected immediately.