UDP Discovery Stopped Working

Hi all. Wondering if anyone has had an issue with this. My server & clients are on the same subnet and my server has stopped being able to detect the clients. I haven’t changed any firewall configurations. Tried disabling firewalls on the server/client and also adding client IPs via hint. I believe the network is able to handle UDP broadcast packets (it was doing that before without an issue and I haven’t changed the config). I’ve only been able to get this to work by setting the clients up as Internet clients. Any suggestions for other things I can try?

Thanks!

1 Like

I should mention that the server is a Hyper-V client. Not sure if that has anything to do with it. It’s been working fine for years.

OK figured it out. That was painful. This was not a urbackup issue. Hyper-V was dropping UDP broadcast packets at the level of the adapter. No idea why. Running the server natively fixed the issue.

Commending here to say we are seeing the same thing. A packet capture inside the HyperV VM shows the broadcasts, but captures outside do not.

To follow up on this, we were able to work around the issue by using a HyperV “legacy network adapter” instead of the regular network adapter. It appears that a recent HyperV update broke broadcast traffic for regular network adapters (at least for generation 1 VMs).

1 Like

Had the same problem, after uninstalling KB5015811 on the Hyper-V server it works again.

1 Like

Can you share with us full experience:

  1. Hyper-V host OS version and build?
  2. Hyper-V VM generation, net adapter version legacy or new, Hyper-V switch version?
  3. Do you disable offloading and VMQ in Hyper-V VM net adapter settings, NIC teaming?
  4. Do you disable GRO, LRO for UDP/TCP in guest OS, and what guest OS you use?
  5. UrBackup server and client versions, installation sources?

Useful commands and resources:

Disable-NetAdapterVmq *
Disable-NetAdapterChecksumOffload *
Disable-NetAdapterIPsecOffload *
Disable-NetAdapterLso *

Thank you!

Had the same problem, after uninstalling KB5015808 (Hyper-V 2016) and KB5015874 (Hyper-V 2012R2) on the Hyper-V server it works again. Now I’m looking for Hyper-V 2022 (the problem remains). You have to look for the parameter to be fixed so as not unistalling KB in all server version.

Does anybody know exactly what is being restored by uninstalling KB5015808? What “parameter” are you looking for to be fixed? I’ve been struggling to find any other recent reports of this behavior more broadly, want to avoid installing on bare metal to fix the issue, and want to avoid having to hold back certain updates.

Hello.

After the August Windows Server updates, the problem persists. UrBackup servers are Debian or Ubuntu based virtual machines. This probably has to do with the size of the UDP packet:

For me, it was temporarily helpful to turn off the virtual machine for outgoing checksum traffic:

ethtool -K eth0 tx off

Regards

Thanks for sharing that command. Works like a charm with

ethtool -K eth0 tx off

You have to execute it after every reboot but I see that as a plus as the changes are gone after a reboot.

I fixed in Ubuntu 20.04.4 by editing the .yaml configuration file used by netplan.
Example:
network:
ethernets:
eth0:
addresses: [192.168.1.167/24]
gateway4: 192.168.1.254
nameservers:
addresses: [4.2.2.2, 8.8.8.8]
tcp-segmentation-offload: false
tcp6-segmentation-offload: false
receive-checksum-offload: false
transmit-checksum-offload: false
generic-segmentation-offload: false
generic-receive-offload: false
large-receive-offload: false
version: 2

You must have netplan.io updated to version 0.104, previous versions have a bug that does not disable offloading.
View article… https://bugs.launchpad.net/netplan/+bug/1956264
Updated Ubuntu …

Regards

1 Like