Linux Urbackup Client permanetly fails (ERROR: Error getting filelist)

I’m testing Urbackup since 2 month now and I like it – Thank you Martin.

Unfortunately, one linux-client does not work at all. All others, my Linux-WS (stretch), a couple of win7- and debian-VMs work like charm.

The client in question is the nas, where the Urbackup-server runs.
it always errors with:

2017-02-28 11:14:37: nas.dei.privat: Doing backup with hashed transfer...
2017-02-28 11:14:37: nas.dei.privat: Loading file list...
2017-02-28 11:14:37: Flushing FileClient...
2017-02-28 11:14:37: ERROR: Error getting filelist of nas.dei.privat. Errorcode: CANNOT_OPEN_FILE (3)
2017-02-28 11:14:41: ERROR: Backup had an early error. Deleting partial backup.


nas: odroid XU4 (armhf) with debian jessie.
urbackup server: (same with 2.1.18)
urbackup client: (same with 2.0.36)
OMV: 3.0.64
OS on eMMC,
Data on /dev/sda1,
Urbackup on /dev/sda2

I changed the TMP-dirs, since /tmp is a too small ramdisk which was the source of other errors




besides this, all configs are default.


boot from eMMC:

$ parted /dev/mmcblk0 p
Model: MMC SDW16G (sd/mmc)
Disk /dev/mmcblk0: 15,8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  555MB   554MB   primary  fat32           boot, lba
 2      555MB   6400MB  5845MB  primary  btrfs
 3      6401MB  12,4GB  5965MB  primary  btrfs
 4      12,4GB  15,8GB  3392MB  primary  linux-swap(v1)


$ urbackupclientctl list-backupdir
PATH          NAME     FLAGS
------------- -------- ------------------------------------------------------
/srv          srv      symlinks_optional,one_filesystem,share_hashes
/var/urbackup urbackup symlinks_optional,one_filesystem,share_hashes
/             root     symlinks_optional,one_filesystem,share_hashes
/boot         boot     optional,symlinks_optional,one_filesystem,share_hashes
/home         home     symlinks_optional,one_filesystem,share_hashes
/var/lib/lxc  lxc      symlinks_optional,one_filesystem,share_hashes

all btrfs-partitions are on subvolumes
It does the same when i only backup “/” + “/boot”


Debug-logs are sent to

I have seen other, unanswered threads here in the forum, reporting the same pbl.
So I hope to get a solution to the pbl., which is bugging more people


You have a urbackup backup name and the name clashes with an internal name. I will fix this, but as a work around you could rename that backup path or remove it.

It does the same when i only backup “/” + “/boot”

i renamed the urbackup to var-urbackup, but as I already wrote, it does not change anything.

Have you restarted the client afterwards? If yes, could you send me the client debug log again? It could be a different problem.

after restart of the client, it worked. :slight_smile:
I can’t explain why, since I’ve tested more then a dozens variants, even backing up only “/” & “/boot” (after fresh install) all with the same error, suggesting that there is another culprit…

it works for now. it even survived another restart of server & client.

for the time being, it’s ok. I will watch the issue.

merci vielmals.