Is there a way to change the date format in the web interface?


#1

I’ve started using Urbackup recently, so far it’s great - a very efficient and easy to manage way of backing up windows machines. The only problem (it’s a minor one) is that dates in the web interface are in a really weird format. For example last seen is 24/17/09 12:26 (today is 24 September 2017). To me that looks like DD/YY/MM which is a format used nowhere in the English-speaking world as far as I know.

Is there a way to set it to either YYYY-MM-DD or DD/MM/YYYY ?


#2

Weird, it’s DD/MM/YY in mine.


#3

MM/DD/YY here.


#4

What’s the date format on the machine you’re viewing on? I’m in UK so my machines are set to DD/MM/YY OS wide, are you guys in the USA or some other region that displays dates in the wrong order routinely?


#5

I’m in Australia so my system (Ubuntu 16.04) is set to the normal (for us) DD/MM/YYYY.

I’ve just found something interesting, since my Urbackup server runs on a Linux server that I don’t normally login to using the GUI I normally access Urbackup’s web interface by forwarding port 55414 over ssh to my local machine. This is where I see the weird date format.

But if I instead start up a desktop (KDE) on my server and run the Firefox browser locally there, and login to http://localhost:55414/ locally with no port forwarding the date formats appear correctly in YYYY/MM/DD. So it looks like accessing Urbackup’s web interface through a port forwarded port messes up whatever javascript it uses to determine the date/time format.

Maybe it can just be added as a config option?


#6

did you tried to change the language at the very bottom left ?


#7

Changing the language does not help - I tested changing to German, French, Brazilian Portuguese. None of it made a difference


#8

Interestingly, this issue only happens on Firefox. If I use Chrome, even over SSH port-forwarding, the date displays in the correct format for my locale (DD/MM/YY)


#9

Firefox (and other Mozilla browsers like Seamonkey) have umpteen different regional installers, did you install en_us, if they don’t do an Australian variant, try the uk installer for firefox, maybe it’s trying to be too clever and “correct” the date format.

there could be something in about:config in firefox too… but there’s so many settings there your eyes will glaze over.


#10

I’m using the Firefox installed with Ubuntu (i.e the deb package that comes from the Debian and Ubuntu repos). I’ve set my system to English (Australia). That’s not really the issue though, since no English speaking country uses DD/YY/MM.

The problem seems to be that whatever Javascript the user interface is using to try and get the date/time format from the system is failing when I access the interface over ssh forwarding in Firefox


#11

What does it show if you open the scratchpad (SHIFT + F4) and execute:

alert(new Date(2013, 9, 25).toLocaleDateString());

?


#12

I get:
10/24/2013


#13

I get:
10/24/2013

In about:config my general.useragent.locale is en-US (which is the default value)


#14

Which Firefox version is that?

I wonder how/why it shifts the day part of the date one day back…Perhaps because of australia?


#15

Firefox 56 from the Ubuntu packages. I don’t understand why it does that either, possibly because of Australia (Sydney is either GMT+10 or GMT+11 dependening on DST).


#16

I’m also getting this… I’m in Australia too, but get the US format…

Is UrBackup using Javascript for this? If so, it’s a known issue with Firefox and Chrome handling things differently, and it seems neither want to change their ways. Adding the locale name to .toLocaleString(“en-AU”) fixes it in Firefox, but I haven’t looked at Chrome, nor have I checked if this is what UrBackup is doing.

I find it really frustrating as an Australian, and often think my backups haven’t run for several days and start to panic.


#17

The issue in this thread should be fixed with server 2.2.x. If you have a new problem please open a new thread and describe the problem in detail. Thanks!


#18

It’s not. 2.2.10, still showing 11/08/18 for a backup done yesterday. Which is exactly what this thread was about. I can open a new thread, but it’ll just be a link to this one because I’m not retyping all the information contained here.


#19

Ok, sorry about that then.

I have no idea why it’s not fixed…
If possible can someone debug this function https://github.com/uroni/urbackup_backend/blob/2.2.x/urbackupserver/www/js/urbackup_functions.js#L386 that determines the date format (CTRL + SHIFT + I in firefox)?


#20

Also, could you repeat that.