Installing on freenas results in error libdl.so.1 not found


#1

installing on freenas results in error libdl.so.1 not found which is required by urbackup- when attempting to launch service.

I tried following instructions at

https://www.urbackup.org/freenasserverinstall.html

any idea what is causing that?

Thanks


#2

also when restarting jail- with http:// 192.168.1.64:55414 it says site not found


#3

@kcoombs


#4

I made a not fully tested tutorial for FreeNAS iocage. That may help. This guide uses FreeNAS new UI 11.2 with iocage jails.

Creating the Jail
Create a jail in the new UI from FreeNAS 11.2 (press on the + icon in the upper right of the screen)
Choose a jail name. I chose : Urbackup
Select the release : 11.2-RELEASE
Click Next.
Configure network : i’m a noob in the area. This is what worked for me.
IPv4 interface. I chose my interface em0
IPv4 Address: i chose a static IP outside my DHCP : 192.168.1.96. Highly depends of your network configuration. You may also choose DHCP.
IPv4 Netmask : 24
Click Auto-Start.
Did not change the rest.
Click Next then submit.

Stop the jail.
Create a mount point
Source urbackup in tank
Destination /mnt/backups

Make sure the jail is started : again click on the 3 small dots far right

SSH into the Jail
You have several ways to SSH into the jail. I use XShell (free for home). This is not the scope of the tutorial. I will not answer questions about how to connect to FreeNAS using SSH. You can copy and paste the below commands if there is any doubt about spaces or format issues.

Type “iocage list” to make sure your jail was successfully created.
Type “iocage console Urbackup” (chose the right jail name) to enter in the jail.

https://www.urbackup.org/freenasserverinstall.html

pkg update
pkg install cryptopp
or
pkg add -f cryptopp-5.6.5_4

Or like I do with Urbackup beta : Download the latest urbackup. Copy it to root folder with Winsc

tar xf urbackup-server-xxxxx.tar.gz
cd to the folder

./configure
make install -j4

To automatically start UrBackup on jail boot:

Add to rc.conf

/usr/local/bin/urbackupsrv run -d -g 104857600 -u root

Restart the jail : (exit the iocage jail first)
iocage restart Urbackup

Browse to http://jail-ip:55414 and configure an admin user and the backup storage path.

miscellaneous : Migrate from another server:

root/var/urbackup
ou
root/usr/local/var/urbackup

miscellaneous: Location of backups (à créer)

root/var/backups
ou
mnt/backups

miscellaneous: Location of Logs

/root/var/log

miscellaneous: Server remove unknown tweaked

urbackupsrv remove-unknown -u root


#5

Thanks seems to have worked under freenas 11.2 RC and new interface.

I get the UI interface now for Urbackup- now just to test if works with client

Thanks

Mail](https://go.microsoft.com/fwlink/?LinkId=550986) for Windows 10


#6

Hello,

i do not seems to found the pkg cryptopp-5.6.5_4
and seems to have issue compiling with cryptopp-7

where can i get this package