Install Urback on CentOS 7 basic installation without E-Mail support


I`ve tried UrBackup an a WIndows PC as a server and this was a great susccess for us. This is exact the backup technologie for our clients, we are lokking for.

Our production backup server (BazaarVCB for ESX Backup and samba for Symantec Backup) is planed to be the machine for UrBackup too. We are runnig a CentOS 7 basic installation on this machine.
Is there a step by step guide for installing UrBackup on this machine? I could`t find anything on the Web.

Any hints?


In CentOS (as Ubuntu/Debian) you need to build manually Urbackup client and server. When you building UrBaсkup server on CentOS, you need to use this manual (to base only):
but I had some problem with build from source. This is “old” packages in the repositories. Now I trying build libcurl manually from source…

Classic build process looks like this:
1). install need depending
2). ./configure
3). make
4). make install (clean)

Thanks for your assitance.

I did the following commands.

  • I dont know, i fits nessecary, but I need it for vmware tools to take snapshots
    yum –y install perl

  • downloading the software development packages, being able to compile the sources
    yum –y groupinstall Development\ Tools

  • Downloa the UrBackup Sources

  • decompress the package
    tar xzf urbackup-client-1.4.5.tar.gz

  • go into the directory with the source files
    cd urbackup-client-1.4.5

  • run configure
    after some seconds the following error appears.
    checking for gettimeofday… yes
    checking for memset… yes
    checking for strstr… yes
    checking for wx-config… no
    configure: error:
    wxWidgets must be installed on your system.

      Please check that wx-config is in path, the directory
      where wxWidgets libraries are installed (returned by
      'wx-config --libs' or 'wx-config --static --libs' command)
      is in LD_LIBRARY_PATH or equivalent variable and
      wxWidgets version is 2.9.0 or above.

configure: error: ./configure failed for client

what do I have to install to get wxWidgets 64-bit on my machine?
I hope I`am able to finsh my installation.

Any hints


Few days ago I wrought this topic:

I hope this help you.

PS Key words: “build wxWigets ver. 2.9.5 with --prefix=/usr”
In this part of forum, I created a topic:

While I have not tried to build libcurl manually. I will try later.

Hi. You can use repo with binary packages:

Just follow the instructions.


thanks for this information. This installation works without any problem, but there the UrBackup website can`t be access at port 55141 at the Linux machine.
The firewall and selinux services are already disabled for testing.

Do I still need any startup commands/skripts to start urbackup service at systemstart?

Any hints?


Hello, can you post here output of:

  • netstat -ptln | grep urbackup
  • pstree -p | grep urbackup
  • iptables -nvL INPUT | grep -E “5541[34]|35623”
  • iptables -nvL | grep -E “policy|REJECT|DROP”

Did you executed: systemctl enable urbackup-server.service && systemctl start urbackup-server.service after installation?


  • Install wget
    yum -y install wget

  • add new repository and install UrBackup
    cd /etc/yum.repos.d/
    yum -y install urbackup-server

  • enable Urbackup as a service and start UrBackup
    systemctl daemon-reload
    systemctl enable urbackup-server
    systemctl start urbackup-server

  • create „example“ directory for the backup files and images
    mkdir /UrBackup-Backup
    chown urbackup /UrBackup-Backup

  • open firewall tcp port 55414 for the standard public zone
    firewall-cmd --permanent --zone=public --add-port=55414/tcp
    firewall-cmd --reload

  • at the end reboot your machine and check everything is running

  • open the http://UrBackup-IP:55414

  • goto settings and add at „Backup storage path:“ the directory „/UrBackup-Backup“

  • now you are ready to install the client software and adjust the backup settings

  • have fun

  • after some days and some finished backup and image jobs try the restore of single files

  • and disaster recovery of an image

Thanks Guido

Btw. there is a firewalld config in the tree .

I’ll try and add those instruction to the admin manual with the next release.

I find it extremely annoying that RPM packages do not automatically startup as service after installation, like Debian packages do, but (@kot1grun) that is the standard, correct?

@uroni , I’ll add firewalld rule to packages for RHEL7-like systems.
Answering to your question, there is one problem described here
We can start it but it’s not recommended. I’ll change the behavior and enable service by default for all systems (but you have to start it manually).
Also, I’ll try to move to new %systemd_ scriptlets (of cause if they are compatible with OBS).


i just found also your rpm builds on OBS

thank you for maintaining this :smile:

When do you expect to get a Centos 7 package for 1.4.9?

Wow! I didn’t notised. I’ll try to do it today.

Thank you so much.

Hi kot1grun

I have used your repository to successfully install the Urbackup Client onto a CLOUDLINUX 6.7 x86_64 system (it was Centos originally). It installed perfectly but the service does not startup so I have to manually start the client by using “/usr/sbin/start_urbackup_client” after reboots.

I have had a look at the /etc/init.d/urbackup-client but the paths do not seem correct for my installation as they refer to /usr/bin/start_urbackup_client and not /usr/sbin/start_urbackup_client which is where mine ended up.

I have tried changing the path in /etc/init.d/urbackup-client to point at the sbin folder but when I try and start it (./urbackup-client start) it gives me the following error:

/etc/init.d/urbackup-client: line 129: syntax error: unexpected end of file

And line 129 just has
exit $retval

Are you able to offer any insights into what I am doing wrong?

Mark Donne

This is how I installed:

Centos 7 x64bit urbackup-server-2.0.36

yum install autoconf automake binutils bison flex gcc gcc-c++ gettext libtool make patch pkgconfig redhat-rpm-config rpm-build rpm-sign
yum install zlib-devel.x86_64 zlib.x86_64 libcurl-devel.x86_64 cryptopp-devel.x86_64

wget “
tar -zxvf urbackup-server-2.0.36.tar.gz
cd urbackup-server-2.0.36/
make install

systemctl disable firewalld && service firewalld stop

To start
/usr/local/sbin/urbackupsrv run

Browser to