Image Backup Constantly Fails


Using Client 2.2.6 with Server 2.2.10.

I have one PC which refuses to complete the image backup. The server is located on a VPS so speed is slow (about 6Mbit/s) so backing up by 512GB SSD takes up to 5 days! But it always fails after about 20-30% with the same type of error:

Errors 13/12/18 05:11 Error on client occurred: Error while reading from shadow copy device (1). The device is not ready… Shadow copy \?\GLOBALROOT\Device\HarddiskVolumeShadowCopy461 not present anymore. May have been removed
Errors 13/12/18 05:11 Backup failed

What is causing this please?



Make sure there isn’t another software initializing/calling for a vss snapshot, and that System restore has enough space to maintain multiple VSS snapshots (System | System Protection)

Updates, SQL servers and maintenance plans etc. Check your event viewer for the time the backup fails for items running.

After that you’ll have to enable debug on the client for more info

Hi - sorry, really not sure what that all means!

What is a VSS snapshot? Where do I configure those? How much space is enough - I have a 512GB SSD which has about 40GB free.

This just seems to stop at random times - because the disk is large, it does take 5-6 days to backup over the Internet.


Here’s a good tutorial on dealing with VSS shadow copies. I recently used Option Three in that list to fix an image backup difficulty. I wasn’t too concerned about computer damage as I had good image and file backups that were recent enough.

There are several other HOWTOs on the web if this one is not your style.

VSS is how Windows creates snapshots for disks for backup. Everything you overwrite while a backup is running needs to be copied to “shadow storage”. If you overwrite more than 40GB during the backup the backup get’s interrupted because Windows automatically deletes the snapshot.

This can also be changed via UI in the advanced system settings -> system protection tab for each disk.

Hmm. Well, that didn’t go well. Three days backing up the system and got 20% of the way through before for no apparent reason, it stops with a rather terse message in the log:

Errors 15/12/18 13:42 Error on client occurred: Shadow copy not found. May have been deleted.
Errors 15/12/18 13:42 Backup failed

Maybe someone could just tell me the correct settings (i.e. those that are known to work) in all the bits of software I need? This is a bog-standard Windows 10 installation so I’m suspecting that there must be a document somewhere that details how to set up the backup software correctly?

Also, if it has already worked on other Windows systems, what could possibly be different in this Windows system?

Thank you in advance.


You’re probably running out of free space. Erase files or upgrade SSD to 1TB.

Not upgradable - it’s a Yoga 900 with a fixed SSD and the whole unit appears to be glued together…

How much free space do I need to back up a 512GB disk?

That’s subject to a lot of factors, including how active the machine is at backup time with regards to disk writes especially…

My personal “rule of thumb” for anything running Windows is keep 20% of the disk free.

A quick google turns up results (and videos) for how to replace/upgrade the hard drive on these if you want to.

1 Like

Hmmm - 1TB SSD from Crucial £226! So THAT’S not happening any time soon! Plus whatever it costs to have someone make the change for me which I suspect will be at-least another hundred quid…

The files appeared to have backed up OK - it’s just the image that is failing so I’ll try and live with it like that for now.

You could see what your mileage is trying windows image backup, though if the issue is VSS running out of space you’ll likely hit the same issue, as would any tool imaging the system while it’s running, they all use VSS to do it.

If you really want to have an image for emergency recovery and can’t free up the space to stop VSS failing, you could work round the issue using any tool that takes offline images… Clonezilla, or something like the Macruim reflect rescue environment (booted from USB/DVD).

1 Like

So on my Win10 pc my backups were also failing for some reason and i could not understand why. I then saw my Maximum space allowed is 10GB. This is just my assumption but i think this is how the process works, @uroni please correct me if im wrong.

When you start a backup, a snapshot of your PC is taken and then that is what UrBackup will actually back up. Remember, while your pc is now backing up, the system files still update. so these changes to documents, system files and so on are then written to the shadow copy (in my case the maximum allocated space was 10GB). So what happen is that when this allocated space is full, your pc then deletes the shadow copy as its full. this is then what causes your backup to fail.

You will see i bumped up the maximum allows storage to ± 100GB, im busy backing up now. i will post again to advise if it solved my problem

Use these commands in CMD (administrator)
vssadmin list shadows
vssadmin list shadowstorage ( wil your backup is running use this to see how the shadow copy storage is being used.)

I hope this helps