I think I broke UrBackup

I think I have been too impatient with UrBackup and I’ve probably broken it. I wonder if anyone can help me resolve it.

Here’s what I did.

  • Created a new internet client
  • Downloaded the windows client and installed it on the client machine
  • I did not want to do an image backup but the installer doesn’t give me the option to not do an image backup. But I thought I had disabled it on the server configs (turns out I had disabled it for a different specific client config)
  • The client machine started doing a full image backup over night which I found the next morning
  • I tried to stop the job
  • rebooted client and server but server was still trying to process it
  • I deleted and re-installed the client and ensured the config on the server disabled image backups
  • It still tried to continue the image backup!
  • I am using cloud storage and now it is trying to sync the partial backup and won’t allow me to stop it.

I just want to backup one specific file as a test. I set this on the client but it is still insisting on completing the image backup. I don’t want image backups!

I’ve tried to force a clean-up on the server but it keeps saying that it can’t find the free space.

# urbackupsrv cleanup -a 1%
2020-09-25 11:45:55: Shutting down all database instances...
2020-09-25 11:45:55: Opening urbackup server database...
2020-09-25 11:45:55: ERROR: Error getting free space

Any help to stop syncing the partial backup, and just make the client backup the ONE file that I selected, would be most appreciated!

Now that the sync to cloud storage has finished, I have been able to run the clean up. But the storage is still showing that it is using 65% (the other two clients should use about 1%)

I then ran remove-unknowns and then ran cleanup with a higher percentage to cleanup and that seems to have worked with the stats.

So the lesson here is “Get it right first time, or wait a LONG time”

OK, it seems that UrBackup “does not forget” and it refuses to apply new settings unless you complete your first full backup. So if you have the wrong settings, you are stuck. At least that’s what it appears to me so far.

So I had created a client with the name callington. I deployed the pre-configured windows client and it tried to do an image backup. But I don’t have enough storage for image backups (and I don’t want them anyway).

So I eventually deleted the client and backups from the server. I uninstalled UrBackup from the client machine and rebooted.

Then I did a clean install of the client software using the “vanilla” client from the UrBackup site.

I have completely disabled image backups in every place I can think of and I have enabled 2 directories for backups.

But it STILL insists on doing a full image backup first!

Here are some screenshots and outputs of what I have on the client and the server


C:\Program Files\UrBackup>UrBackupClient_cmd.exe list-backupdirs
PATH                                                           NAME               FLAGS
-------------------------------------------------------------- ------------------ ----------------------------------------------
C:\Users\administrator.<redacted>\Downloads\SSMS-Setup-ENU.exe SSMS-Setup-ENU.exe follow_symlinks,symlinks_optional,share_hashes
C:\scripts                                                     scripts            follow_symlinks,symlinks_optional,share_hashes



Also here are the logs from the client on the initial backup. As you can see, it seems to still be trying to backup the SQL Server database. I haven’t configured SQL Server backup anywhere so I am not sure why it tried to do that (unless it was part of the image snapshot).

Starting scheduled full file backup...
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Component caption= name=CALLINGTON
Indexing of "SSMS-Setup-ENU.exe" done. 1 filesystem lookups 0 db lookups and 0 db updates
Indexing of "scripts" done. 2 filesystem lookups 0 db lookups and 0 db updates
callington: Loading file list...
callington: Started loading files...
Building file search index...
Waiting for file transfers...
Waiting for file hashing and copying threads...
HT: No free space available deleting backups...
HT: FATAL: Error freeing space
Metadata file and "/media/backup/backups/callington/200925-1901/.symlink_SqlServerWriter_{A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A}_e5e7596d2d3a357ad5b42a207575cf99_big.bb.dev_files00000000/big.bb.dev.mdf" (id=38) do not exist. Skipping applying metdata for this file.
Writing new file list...
All metadata was present
Transferred 72.5668 GB - Average speed: 28.1217 MBit/s
(Before compression: 953.807 GB ratio: 13.1438)
17.1445 KB of files were already present on the server and did not need to be transferred
FATAL: Backup failed because of disk problems (see previous messages)
Time taken for backing up client callington: 18h 5m 44s
Backup failed

Should I delete the whole /media/backup/backups/callington/ directory on the backup server and try again?

  • Set min number of incremental/full image backups to zero so it can delete image backups
  • Set default=0 for the Windows component config in the advanced settings to not backup SQL server
  • Disable Allow client-side changing of settings in permissions or do not configure any setting on the client side if you want server side configuration to work. This includes clicking on “ok” instead of “cancel” in the setup wizard

A client debug log is helpful in pinning down what happend in detail (See Having problems with UrBackup? Please read before posting )

Thank you @uroni!

Please correct me if I’m wrong, but if I disable client-side changing of settings then I can no longer add backup paths using the CLI.

I wanted to control all settings and jobs from the server, but set/remove backup paths from CLI.