GUI not show older backups

Hi all,

Recently we had a problem with disk where OS istalled, then we replace the disk and reinstall os and Urbackup Server.

On other disk which store the backups (storagefolder) we have a Raid10 4tb with btrfs partitions.

To troubleshoot we store the files on /var/urbackup in a Symlink to folder on urbackupfolder and restore this link.

2nd Step, we ran urbackupsrv remove-unknown, and it take a lot of time.
after when we start server, older backups are not showed on gui, but the file and folder are stored on this partition and visible on terminal

i think is it can be a permission prioblem, however i still not solved this , so curious but the owner of folder is geoclue/ group saned

Is UrbackupServer running as geoclue? if not, change them to what urbackup is running and it might fix it.

It might have to do with your new urbackupserver installation got a different UID and GID than it had on your old installation. If you are curious, you can use ls -n to get numerical ids instead of names.

Thanks @bedna i really need to change, but btrfs don’t let me change, it show a message this file is read only

do you have any idea how to can solve this?

Try unmounting it, chmod the mountpoint and then make sure you have everything correctly set in fstab and remount.

Without more info than “it wont let me change” it’s impossible to know.

Edit. Is this what you are looking for? Reinstall OS where urbackup server is - #4 by rlopez
edit 2. LMAO, I just realized the answer is directed TO YOU in that post. xD

Bedna, Forgive me i’m a newbie in this community LMAO, maybe i don’t express this on a right form

this is one example of output of CHOWN:

chown: alterando o dono de ‘ESTACAO-16/230518-1259/Desktop/FENACOR - Atalho.lnk’: Sistema de arquivos somente para leitura

in rlopez topic, i also interacted.

i tryed to “btrfs property set -ts /urbackupfolder ro false”

but this is that output

ERROR: Could not get subvolume flags: Invalid argument

when apply in mountpoint it no show output, but it don’t takes effect.

Was it mounted or unmounted when trying to change the property?

What does your fstab look like? What is the structure of your btrfs?

what is the output of sudo btrfs subvolume list /path/to/backup