File backups failing with Cannot access path to backup and Path Contains Wildcards

I’ve been having this problem recently and have seen numerous posts on here regarding this error.

Info: Server - Ubuntu 18 VM running on Gentoo host - Urbackup server version 2.4.12
Client: Windows 10 Pro - UrBackup Client version 2.4.10

My client log looks like:

Level Time Message
Info 06/26/20 09:58 Starting scheduled incremental file backup…
Info 06/26/20 09:58 Scanning for changed hard links on volume of “C:”…
Errors 06/26/20 09:58 Cannot access path to backup: “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy91\Users*” Errorcode: 123 - The filename, directory name, or volume label syntax is incorrect.
Warnings 06/26/20 09:58 Hint: The directory to backup contains wild cards. This is not supported. Please use the include and exclude settings to accomplish what you want
Warnings 06/26/20 09:58 Hint: Directory to backup (“C:\Users*”) does not exist. It may have been deleted or renamed. Set the “optional” directory flag if you do not want backups to fail if directories are missing.
Errors 06/26/20 09:58 Indexing files failed, because of error
Errors 06/26/20 09:58 Constructing of filelist of “KITCHEN” failed: error - index error
Errors 06/26/20 09:58 Backup had an early error. Deleting partial backup.

Many posts have mentioned problems with the shadow copy server or OneDrive, but, in my case, I think I’ve found the problem and thought I’d post in case it helps someone.

My Included files (with wildcards): setting was:
C:\Users*; C:\DOS*; etc etc etc
And I’d always get the shadowcopy error above plus the “C:\Users*” contains wildcards error

I found that it only happened when the first path had a * in it. So, I added A:\ to the front:
A:;C:\Users*;C:\DOS* etc etc etc

And it works properly (I have no A: drive, by the way).

Your Mileage May Vary.