File backup error 123: Cannot access path to backup


#1

I had to take the error message out of the topic title, because the forum told me the title seems to be unclear…
Anyway:

We’ve got a windows small business server 2011. urbackupclient is 2.1.16 and server 2.1.19. So far the file backups worked without any problems, but now the server started to fail the backups. Independed if it’s a full or incremental backup. The image backups work fine.
It shows following error message:

31.05.17 15:02  	ERROR  	Cannot access path to backup: "\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy394\wsus\susdb\\updateservicesdbfiles" Errorcode: 123 - Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
31.05.17 15:02  	ERROR  	Cannot access path to backup: "\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy394\wsus\susdb\\updateservicesdbfiles" Errorcode: 123 - Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
31.05.17 15:02  	ERROR  	Constructing of filelist of "GastroBL-Windows-SBS-2011" failed: error - index error

The german part means something like that either the syntax for the path is wrong or the volume name is wrong.
I tried to completely deinstall and reinstall the urbackup client.
Eventhough I’m pretty sure it is a client problem I exected on the server: repair-database and remove-unknown.
Still the same error appears. Then I tried to add “C:\WSUS;” to the exclude paths on the server for that specific client, but still the same error appears (Even it really shouldn’t?).

Anybody got any idea how to solve that one? I couldn’t find any solution in the other threads which mention similar errors.

edit: some typos


#2

Sorry you are having issues. To solve the problem the client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting

Thanks!


#3

sorry about the debug log, I’ve forgot to mention, that I didn’t attach it, since it states the exact same message (and nothing else, well at least as far as I could see).

I’ve sent it to bugreports@urbackup.org


#4

Looks like the path comes from the VSS component backup (MSSQL?). Maybe there is a WSUS component you can deselect?


#5

I found “SUSDB” below the ms sql writer.
But I can’t deactivate it. When I uncheck it, click ok, and then open the settings again, it is checked again. Whatever component I try to check or uncheck, it does not save the changes. No error message appears, also not in the debug.log. The client does have the permission to change component backup.
I tried to uncheck it, and do the backup, but the error appears, so it seems like it really does not save the changes to the components…


#6

Did you give the client permission to overwrite settings?


#7

ok that was the problem. To be honest, it’s not too logical that you need to activate “Allow client-side changing of settings” for the setting “Allow clients to configure components to backup” to be working (especially since the client doesn’t give any error message)…

anyway. I deactivated the backup of the SUSDB database. And now the backup works like a charm. Thanks a lot for your help :-).

Do you want to find out, what exactly causes the problem? Any infos I could give you?


#8

Any fix to this? “Allow client-side chancing of settings” and all the other permissions are checked. I’m getting the exact error the OP got. I only have this problem on a windows client. On a linux machine it runs normally. It used to work on this Windows machine too. I’ve tried reinstalling the client but that didn’t work. Any help? Nothing’s working to fix this.