File Backup does not work on windows 10 machine


#1

Hi,
I am using urbackup on OMV 4 (urbackup Version 2.3.7) and Client Version 2.3.4.

Thanks for your great work, urbackup already saved one of my pcs, when the drive didnt work anymore.

I have the problem that one client has many errors (my personal pc).

Level Time Message
Errors 06.02.19 12:22 Cannot open file \?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2\Mount\Program Files\Common Files\Microsoft Shared\ink\TabTip.exe to read the FRN. Das System kann auf die Datei nicht zugreifen. (code: 1920)
Errors 06.02.19 12:22 Cannot open file \?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2\Mount\Program Files\Common Files\Microsoft Shared\ink\TipRes.dll to read the FRN. Das System kann auf die Datei nicht zugreifen. (code: 1920)
Errors 06.02.19 12:22 Cannot open file \?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2\Mount\Program Files\Common Files\Microsoft Shared\ink\tabskb.dll to read the FRN. Das System kann auf die Datei nicht zugreifen. (code: 1920)

And many other stuff (all in all over 24000 errors).

I have deactivated shadowcopies and deleted almost everything throug the cleaning tool from Windows 10. Running Windows 10 1803.

It has also different errors but without HarddiskVolumeShadowCopy

Before I deleted and deactivated shadow copy it gave errors about HarddiskVolumeShadowCopy17 and now HarddiskVolumeShadowCopy2.

Windows Components are off and I deactivated client site settings.
I also tried switching windows components through GUI with Default=0 as off, didnt help.

I completely deinstalled the client and reinstalled throug configured installer downloaded through the webgui.

The client shows no errors not even information in protocolls, only the data of backup.

Is there anything I can do?

For first I try to exclude *\HarddiskVolumeShadowCopy* maybe this helps.

I also excluded *\OneDrive* on the server (client has different settings, but there are not relevant anymore when I switch off that clients can change settings, right?).

But:
Errors
06.02.19 12:22
Error while getting files in folder “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2\Users\MYNAME\OneDrive”. SYSTEM may not have permissions to access this folder. Windows errorcode: 3
Errors
06.02.19 13:48
Error getting complete file “zUgdfHWWo8uJKNlhz25p|C/Users/MYNAME/OneDrive” from MYNAMES-PC. Errorcode: CANNOT_OPEN_FILE (3)

Greetings from Germany.


Global settings ignored with client setting
#2

For the

Check your drives SMART then chkdsk /r
Now you know you’re not having an underlying disk/file system issue

Urbackup by default runs as SYSTEM so make sure the ACL’s on those files have SYSTEM access.

\GLOBALROOT\Device*

Is the hidden VSS data area Urbackup copies data from after VSS snapshotting the volume pre-backup. Don’t mess with anything in that folder. You may be having VSS problems, do vss troubleshooting steps on the system.

Issue 2: Onedrive is doing special things with the file system when it’s “Save space and download files as you use them” option is enabled which isn’t VSS compliant. Uncheck that option under OneDrive settings to get the files backed up and remove the Urbackup error. See


#3

Thanks for the answer,

How do I check for VSS problems?

I believe my client ignored that I have forbidden the change of client settings, because before all clients could make their own settings.
Reinstalled while the settings where forbidden and he didnt ask which volumes etc.

I now made this change, because their was now no default path configured anymore (before it was just empty)

Permission look like this:

But it shows this error:

Info 06.02.19 22:10 Starting unscheduled full file backup…
Errors 06.02.19 22:11 Cannot access path to backup: “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy10_NONUSB” Errorcode: 2 - Das System kann die angegebene Datei nicht finden.
Warnings 06.02.19 22:11 Hint: Directory to backup (“ALL_NONUSB”) does not exist. It may have been deleted or renamed. Set the “optional” directory flag if you do not want backups to fail if directories are missing.
Errors 06.02.19 22:11 Indexing files failed, because of error

I tried “ALL_NONUSB” and ALL_NONUSB didnt work.

I looked in the C:\Program Files\UrBackup\urbackup\data\settings.cfg and the change came to the client. What do I do wrong?


#4

ALL_NONUSB does only work for image backups, right?
I thought I could use it for all files of all drives for FILE BACKUP.

I have disabled e.g. “allow clients to configure components to backup” but client still shows possibility.

Still why does the client ignores the server settings, the settings are in settings.cfg but he still tries to backup e.g. OneDrive even it is in the exlusion list?


#5

There’s lots of articles out there that walk thru VSS troubleshooting:
https://www.google.com/search?q=troubleshooting+vss+writers

I personally don’t use ALL_NONUSB because there are sometimes partitions with OEM/factory restore etc data and they can be problematic to backup.

I create a group for each computer type: Mac (and Mac Mojave+ while Urbackup is still buggy with those system) / Linux / XP / Win7+
and put the OS into that group.

Then you can create extra groups for limited and unlimited speed backups in each of those categories.

Default directories to backup are per group:
Windows: c:
Linux: /
Mac: /home/