Error creating mountpoint [urbackup_mount_helper]


#1

Hi

UrBackup failes to mount image backups in GUI, mount-button is there, but files doesn’t appear.

UrBackup Server 2.1.18 on Ubuntu 16.04


I tried recovering the UrBackup server from a failed system disk around a year ago, and some back and forth. The server has been running smooth since. I think the problem lies somewhere in the settings, remembering a previous path.

Current backup path is: /mnt/backup1/urbackup

Tried running the mount helper:

:~# urbackup_mount_helper mount CLIENT 170211-1922_Image_C Image_C_170211-1922.vhdz
Error creating mountpoint at "/mnt/backup1/no_dice/CLIENT/170211-1922_Image_C/contents". Err: 2

As you see, the command refers to an old path I used for testing. Found this:

:~# cat /var/urbackup/backupfolder
/mnt/backup1/no_dice

Tried editing the file and restarting the UrBackup service, but still not working. Is the path saved somewhere else? The settings page is showing the correct path:


Mounting images when running in an LXD container does not work
#2

nvm, found a reference in /etc/urbackup/backupfolder, changed this to the correct path and that solved the issue.


#3

Hello! Just comment. This issue occurs when you change backup destination. Then if you trying to mount backup image this error showing in web interface. Solution is to open /etc/urbackup/backupfolder file and correct path with any text editor.