Docker: Mount vhd files

Hi,
I’m using urbackup-2.4.12 in an docker container. I started the container with the “–device /dev/fuse” option to get fuse inside the container.

When I’m open an bash inside the container I test to mount an vhd file:
guestmount -a myvhdfile.vhd -m /dev/sda1 /mnt/

This is working and I can browse the content of the file.

When I’m typing in the following command, I get an error.
urbackupsrv mount-vhd --file myvhdfile.vhd --mountpoint /mnt/

Loading FUSE kernel module...
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.19.72-gentoo
Starting VHD background process...
Waiting for background process to become available...
Mounting...
mount: /mnt: mount failed: Operation not permitted.
Mounting failed.

I have compiled the fuse support direct in the kernel, so theres no module.
After this message I’m back on the bash (I can input commands) but the command is still running in the background.

I hope someone has an idea.

Daniel

Hi,
when I run the docker container with the option “–privileged” I can mount the vhd image with
urbackupsrv mount-vhd --file myvhdfile.vhd --mountpoint /mnt/

But I can’t see a mount button in the web frontend.

dsiggi

What does

urbackup_mount_helper test
echo $?

say?

If that does work, assign a shell to the urbackup user in /etc/passwd then run it as urbackup user (su urbackup -c "...")

Hi,

[root@urbackup /]# urbackup_mount_helper test
Backupfolder not set
[root@urbackup /]# echo $?
1

Is there something wrong with my backup folder?

dsiggi

Put your storage path into /etc/urbackup/backupfolder… Which docker container are you using?

Thanks,
I but the name of my backupfolder inside this file and now it works.

I’m using a own dockerimage based on archlinux becaus I didn’t find an image which includes libguestfs on docker hub.

dsiggi