Mount raw images on Fedora 27

I’m running an Amahi-Box that is unfortunately stuck on Fedora 27. I started using urbackup to see if it can take over my Backup needs and so far I am really liking it. The BTRFS integration is awesome!

I also ran two full raw image backups of my Windows machines, which seems to have worked fine, but now I would like to explore the image. Unfortunately, the “Mount Image” button on the server web GUI does not work, giving me the following error:
ERROR: Image mounting failed: Guestmount…
libvirt: error : internal error: is not safe to use from setuid programs
libguestfs: error: you must have libvirt >= 0.10.2 to use the ‘libvirt’ backend
(as also described here: Image mounting failed [2.2.9_centos]) I guess this is because Fedora is based off of REHL.

Now I figured I’d try the docker image, even though uroni mentioned it would not work as it is impossible to mount files/virtual machines in docker. But this thread here seems to have managed to mount VHDs at least (Docker: Mount vhd files - #2 by dsiggi), so I figured I’d give it a shot. I built a docker image and added && apt-get install -y libguestfs-tools qemu-utils to the Dockerfile. I then ran the docker image as the poster above described with --privileged and --device /dev/fuse.
While I do indeed see the “Mount Image” button after this modification to the Dockerfile and the urbackup_mount_helper test returns “MOUNT TEST OK”, trying to mount the file in the Webgui gives me following error:
Mounting image failed. Please see server log file for details.
Error opening backing file /backups/SUTEKI-2IN1/210604-1124_Image_C/Image_C_210604-1124.raw

So, is this a lost cause? Or could I at least manage to somehow browse and fetch data from the image in the terminal?

Well, via command line (without guestfs):

LD=$(losetup -f)
losetup --offset $((512*1024)) --direct-io=on $LD "/backups/SUTEKI-2IN1/210604-1124_Image_C/Image_C_210604-1124.raw"
mount $LD /mnt/image

Right, thanks! Didn’t find this anywhere in the docs. Did I miss it or is it not documented yet?
Edit: I tried it, but it gave me the following error, trying to mount it as root:
ntfs-3g-mount: mount failed: Permission denied

Would I have to mount it as the “urbackup” user?

Edit2: I can mount it with mount -o ro; guess that’s because the snapshots are read only, right?

Also, I haven’t tried this yet, but would exploring this via GUI be possible in the Debian-based recovery image? I.e.just boot the recovery on a client in a VM and then mount the image from a share of the server?