Can't mount a Windows image backup

Hi everyone,

I’m having trouble mounting an image backup from a Windows Server and I can’t find a way to solve this alone.
When I try to mount it using the web interface nothing show up after pressing the ‘Mount’ button.

I’ve tried to mount it using the command line the urbackup server :

#urbackup_mount_helper mount CLIENT 170524-1522_Image_C Image_C_170524-1522.vhd
Loading FUSE kernel module...
Starting VHD background process...
Waiting for background process to become available...
Timeout while waiting for background process. Please see logfile (/var/log/urbackup-fuse.log) for error details.
UrBackup mount process returned non-zero return code

And here’s the the content of /var/log/urbackup-fuse.log :
2017-05-24 15:57:35: Mounting VHD via fuse…
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170524-0916_Image_C/Image_C_170524-0916.vhd”
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170523-0911_Image_C/Image_C_170523-0911.vhd”
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170522-0909_Image_C/Image_C_170522-0909.vhd”
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170521-0903_Image_C/Image_C_170521-0903.vhd”
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170520-0858_Image_C/Image_C_170520-0858.vhd”
2017-05-24 15:57:35: VHD-Parent: “/media/backup-basic/CLIENT/170519-2336_Image_C/Image_C_170519-2336.vhd”
2017-05-24 15:57:35: Volume offset is 524288 bytes. Configure via --offset

My URBackup is running on Ubuntu 16.04. I’ve noticed that the ntfs-3g package is installed. The backup data are stored on a btrfs partition. I’ve also tried to mount other image (including full backup) using the web interface but I’ve had the same results.

Does anyone have an idea or something I could try ? :slight_smile:

I have the same setup and the same issue, ubuntu 16.04, btrfs, server 2.1.19… installed via apt install urbackup-server. No matter if choosing raw, vhd, or vhdx, after clicking the mount button, nothing comes up. I can mount raw successfully via urbackup_mount_helper and VHDs successfully with “urbackupsrv mount-vhd --file…”. I have tried doing an image backup from within a group and out of a group. urbackup seems to have all required permissions. Any ideas as to why the web interface doesn’t display the mounted image?

ok, when running urbackup server as root, it works fine. So what permissions does the urbackup user need to mount raw files in ubuntu?

ok, this fixed it for me…

chown -R urbackup:urbackup urbackup_tmp_files

Running as root or changing owner of urbackup_tmp_files didn’t work for me. The backup is stored on a ZFS store, perhaps that could be a reason?

I ran into this issue yesterday on Ubuntu 14 LTS

I had to set user_allow_other in /etc/fuse.conf and then image mounting worked.

I was finally able to solve my problem :
I luanched urbackupsrv as root and got a few more details about the error. It was due to a problem with libguestfs :
libguestfs: error: /usr/bin/supermin exited with error status 1.

Someone else had this problem already, I was able to find this thread when search about libguestfs on this forum :