Can't find service in raspian


#1

I have installed and reinstalled urbackup. I tried using the debian package and also tried installing from source. No matter what I do, I can not connect to the web interface via 10.10.xx.xx:55414 on any machine or 127.0.0.1:55414 on the local machine.

I’ve looked at the running services and don’t see anything that would resemble urbackup or a web server running. I’m presuming that’s the problem. so, what service name am I looking for? If it’s not there, can I just use systemctl to start it? If I can get it running once, I can then figure out why it’s not starting automatically, I’m just not sure if it’s running period.

I’ve tried systemctl urbackupsrv status, but I get “Unknown operation urbackupsrv.”

I’m running the latest version of Raspbian and UrBackup Server 2.2.11 Debian/Ubuntu jessie+/14.10+ armhf (rpi2+) is what I attempted to install most recently.


#2

Hi,

Run netstat -lnvp | grep ur, you should see something like this:

tcp 0 0 0.0.0.0:55413 0.0.0.0:* LISTEN 18649/urbackupsrv
tcp 0 0 0.0.0.0:55414 0.0.0.0:* LISTEN 18649/urbackupsrv
udp 0 0 10.26.1.11:35623 0.0.0.0:* 18649/urbackupsrv

If this is there a firewall might be blocking connections ?


#3

Hi,

I don’t think this is what I should be getting.

pi@raspberrypi:~ $ sudo netstat -lnvp | grep ur

netstat: no support for `AF INET (sctp)’ on this system.

netstat: no support for `AF INET (sctp)’ on this system.

netstat: no support for `AF IPX’ on this system.

netstat: no support for `AF AX25’ on this system.

netstat: no support for `AF X25’ on this system.

netstat: no support for `AF NETROM’ on this system.

netstat: no support for `AF ROSE’ on this system.

unix 2 [ ACC ] STREAM LISTENING 6086 1/init /run/systemd/journal/stdout


#4

Right - so that shows that there is no server running, also, the command syntax is:

systemctl status urbackupsrv


#5

Hi,

Okay, now I’m seeing segmentation faults which is actually a bit more helpful. I found another thread here https://forums.urbackup.org/t/segmentation-fault-on-raspberry-pi-after-install/4541 which looks pretty similar. I think I may have to try to compile myself again. That took 2 hours last time. Guess I’ll start it and go to bed.

Thank you very much. Believe it or not, I’m more familiar with Solaris from back when I was doing admin work over a decade ago, we ran systemctl servicename stop and start all the time. Didn’t even dawn on me that syntax might be reversed here. Been trying to re-familiarize myself with Unix type operating systems and I’m learning a lot of quirks that Solaris did differently.


#6

All good - good old Solaris - worked on it myself a little…back in the v9 days…was a ROCK solid platform for Oracle :slight_smile: