Segmentation fault on Raspberry Pi after install


I have setup UrBackup on the Raspberry Pi according to this blog howto:

But after succesfull installation all I get is “Segmentation Fault” if I try to start UrBackup
The only logging I can find is in /var/log/deamon.log and it reports:
urbackupsrv[379]: Segmentation fault

Is there anything I could do to debug this installation?
Or could anybody tell me if there is something I’m doing wrong while running the setup.
Without any errors or other logging it is hard to troubleshoot.

Thanks in advance.

Gr. Edo

Note: I have used the latest version of UrBackup:
dpkg -i urbackup-server_2.1.20_armhf.deb
apt-get -f install

1 Like

I have the same problem. Upgraded raspbian from wheezy to jessie in orden to install urbackup server on a pi2+. Installs fine, but never starts. Yields “segmentation fault” even before any log entries are made. Any advice?

Does dmesg shows anything?

Im not sure what you mean. How do I check it?

Open a terminal , type dmesg.
Anyway, what does the full segmentation fault message says?

Did that. No mention of urbackupsrv in dmesg at all. Latest entry is allocation of swap file. On running urbackupsrv it just says segmentation fault, thats it.

and what does the full segfault message says ?

The console just responds “segmentation fault”, as you can see in the screendump.I dont know if there is a way to see more details about the segmentation faults.
regards, J


I would say install symbols then run the server in gdb, but i can t find the symbols.

I guess @uroni will this and provide a “urbackup-server-dbg_2.2.4_armhf.deb”
You ll need to install that and gdb :
dpkg -i ./urbackup-server-dbg_2.2.4_armhf.deb
apt-get install gdb

I am unsure this will help, but while waiting for @uroni answer, you can try this ( most likely, you ll need to redo it once you get the symbols)

gdb urbackupsrv run -v debug
…wait for the crash
copy paste the result

What exact distribution are you guys using? I.e. Debian armhf or Rasbian ? ( And /etc/debian_version )

It’s probably some ARM binary interface issue. That isn’t as stable as could be. If you compile it yourself it should work.

This what I got from the debugger…

Does it help?


I guess it was compiled for a slightly different cpu, and the specific instruction it want to use isn’t available on this cpu (or there’s an real bug there).

If you had trouble running dmesg, maybe compiling yourself is a bit too much to ask, but still you can try :

first :
sudo apt install build-essential “g++” “libcrypto+±dev” libz-dev
then follow this :

Out of curiosity, how long are the configure and make step on a pi (on a “normal” computer it’s like 1 minute) ?


Did you managed to sort that out?


Yes I am close to solving it. I downloaded the source and built it. It is running now. All thanks to your instructions. Thanks. I am not done configuring.
I will post a more detailed anser when I am done. But in short: Yeah it worked.


Sorry about the late response - I’ve been a bit busy.I followed your instructions, downloaded and built the code. Underway, lib-curl was missing. Not knowing which lb-curl I needed I tried with libcurl from openssl, and it seemed to work well.So now the server is running. I find it a bit difficult to configure, but I will figure it out.On the other hand I have two problems:1) My clients are running windows, and sometimes they are very very slow around 50 kb/s in transfer speed. Both my computers are Lenovo Yoga PC’s, and I have read somewhere that these computers have issues related to their power management software. I have managed to make a workaround, using the high power setting and having the computer plugged in.2) The server is unable to get a complete backup without issues see figure 1, with logs (figure 2 and 3).

Figure 1

Figure 2

Figure 3

.Are you able to help with this?

Best regards, J

Try disabling background process in the advanced tab.

The VSS issue is a Windows error. Maybe there are more details that can help fix the problem the Windows System/Application Event Log. So have a look there.