Can't access file backups from WebGUI


Since Server 2.1.8 I’m unable to access my file backups. WebGUI shows a loading bar on top, it loads up and nothing happens. Selecting “Access/Restore backups” gives me a blank page with UrBackup style heading on top. Any hints as to how to resolve this issue?

Tried updating to 2.1.13, didn’t help. Ran database cleanup commands when I was still on 2.1.8, didn’t help too. Behavior seems consistent on all browsers.

OS: CentOS 7

Hi, I am also experiencing this problem after upgrade to 2.1.x. Did you find any solution?

Nope, nothing. I’m not even sure backups are correct at this point :smiley: Keep an eye on this thread too. So far tried different client and server versions (in 2.1.X range) but nothing seems to work.

What OS and UrBackup version are you running on your server?

We are Running Ubuntu 16.04 with zfs for the storage. The clients are a mix of Windows and linux. The backups seems correct as now access them directly from the filesystem instead of the WebGUI

You mean the filesystem on the server? Aren’t the permissions wrong there?

Yes we extract the backups directly from the filesystem on the urBAckup server. Not sure what you mean by permissions, is it Windows ACL permissions they surely are wrong (not sure if they are saved with the backups though)

They are! But they are only restored when the files are restored via client/admin panel. It’s akin to generating a text file with filenames and their permissions to go along the backup - if you only take backup files you don’t access that text file.

My guess is UrBackup actually uses database for that but either way take this as an analogy.

Also, can you test creating a web user, giving him access to one backup and seeing what happens when you try to access “Backups” tab?

Still the same error with 2.1.16. AckRite, did you make any progress on this?
Does uroni have any idea what could be wrong

Nope, same thing, updated, still get nothing shown, CLI bugs out in a similar fashion. Checked ownership, checked permissions, nothing out of the ordinary. Logs are empty on this matter, although maybe there is an extra debug layer I could toggle to see more - HTTP requests are not visible anywhere as it stands.

I realise that I am missing the add new group button and cant find any settings regarding groups (as I beleive is a new function with 2.1.x). I started a separate thread [here] (Group settings missing ) and this could have something to do with permissions in the gui.

Do you see the add group button and have groups set up?

Yeah, I have that one, although it was missing for some time (I think I only got it in 2.1.13?). Maybe I reinstalled (meaning, uninstall and then install) UrBackup then? Are you building source code? This actually might be the issue, maybe it’s necessary to reinstall instead of installing on top?

Yep, building from source. But it sound like you have tried a reinstall instead of upgrade. When you reinstalled how did you preserve the DB files, dick you just copy these from the old install?

They are preserved by default I guess, never had an issue with that. My guess would then be that it doesn’t remove storage path on “make uninstall”, only “bin” type paths.

Can you check what’s your home dir of urbackup user? “make install” wants to create a user with different home dir than what I currently have (not sure if I changed it myself or @Uroni switched folders sometime in development). Maybe that’s the issue?

I did a debug in Firefox and gets the following javascrpt error when trying to browse backups:

TypeError: data.backup_images is undefined
Stack trace:

The error point to this file and row: urbackup_functions.chash-ba3dbff9829eea33c689d82f9020704d.js:241:6 but i am unsure if that’s the real problem.

It seems like I’m getting a responce in the web console with all backups listed so I think the problem is with presentation. I’m not good at java script and most of the page is generated with this so we might need uroni to have a look.

Huh, never thought that bug would be in web code. Output of error in Chrome

Getting same errors on IE and Opera.

Could it be you are using an old server binary? Specifically I removed the one in /usr/local/sbin/ so maybe run rm /usr/local/sbin/urbackupsrv ?

Yeah, running “which urbackupsrv” returns “/usr/local/sbin/urbackupsrv” on my system. Can you add that you your “make uninstall” in next version?

And does it matter where urbackup’s home dir is? Do we need to remove the user and let “make install” add it again?

I don’t think so. I’ll add the rm to the install, but a proper uninstall is out of scope.