Cannot copy directory metadata errors? Hardlink errors?

I am currently investigating backup solutions and have decided to give urbackup a go and it looks quite promising so far (client/server model, restore via web-UI, compression & deduplication).

However, after setting up two backup jobs (one linux, one Win10 to an Ubuntu fileserver via SMB) I see a multitude of errors, which I cannot solve or even understand:

  • Cannot copy directory metadata from "/backups/machine1/201109-1057/.hashes/user/AppData/Local/Keypirinha/default/App/.dir_metadata" to "/backups/machine1/201109-1517/.hashes/user/AppData/Local/Keypirinha/default/App/.dir_metadata". - No such file or directory (errorcode=2)
  • More warnings of kind: Creating hardlink from "/backups/machine1/201109-1057/user/.config/scoop/config.json" to "/backups/machine1/201109-1517/userr/.config/scoop/config.json" failed. Loading file... Skipping.

Any idea what could cause these errors and how I could solve them?

Additionally, sometimes, during a backup, the no. of “files in queue” is climbing instead of decreasing and the amount that was backed up seems to be miscalculated (higher number on the left). Is this normal?

urbackup is used as a docker image (2.4.13) on an ubuntu 20.04LTS server, storage is provided by a TrueNAS server shared as SMB. Both clients show these errors (the hardlink one more with the windows client) and both are the latest version (2.4.10 on linux & windows).

The question would be what happend to e.g. /backups/machine1/201109-1057/user/.config/scoop/config.json. Maybe look at the logs w.r.t. to that?

Actually, the hardlink error apparently solved itself after some restarts. Still don’t know what caused it but I am happy that it worked. :slightly_smiling_face:

Two other things popped up though (it always does, doesn’t it)

  • A backup is stopped/marked as failed because on the source file system (ext4) there are two files that only differ in case (“iLO” & “ILO”) and UrBackup throws an error ("Creating directory "/backups/machine1/201116-2225/[...]/iLO" failed. File exists (errorcode=17)").
    The file exists most probably because the target file system (ZFS shared via SMB) does not support identical file names with different cases.

How should I proceed in such cases (no pun intended)? This time I could delete it because the file/folder was a duplicate anyway, but what to do if this happens with crucial files? Change to a better file system? I could probably share the target folder from ZFS as NFS, but normally that causes more problems… :scream:

  • Second error is: Writing metadata to /backups/machine1/201116-2232/.hashes/opt/tiddly_kingmaker/mywiki/tiddlers/$__trashbin_test.json.meta failed

For the second one I have no idea what is causing this.

You should have gotten a big red warning for that on the status screen with a nice explanation why this problem exists.

Hmm… which error are you referring to? Actually I did not see anything, it just said “No recent backups” in red and the rest was in the error logs.

This one: