BUG .. CBT client causes "Restart required" EVERY startup (unless all volumes selected)

In addition, it ALSO shows CBT active for the ONE volume it’s NOT set to be active, and the ones set to use it are shown as “Without CBT”, and yes I’ve run an image over those (and not the one showing active) and rebooted multiple times!

Windows 10 Pro x64 all updates current.

I have:
Run the windows troubleshooter rebooted as it said - no change
Uninstalled the client - rebooted - blessed silence from the notification bar
reinstalled the client - issue back
rebooted 3 times - notice that I need to reboot at EVERY BOOT including the third one
set it to not use CBT - issue STILL there

this is the one client where I actually need CBT but it WILL NOT WORK without extremely annoying popups - and then it’s random about if it shows active or not.

How do I either:
get it effing working

Cause UrRbackup to serve the NON-CBT client to that specific machine
Note that that’s the worst case option, I’d actually like CBT working on this box.

I only have the machine on site for a limited time and need to fix this NOW, not the week after next when I can’t access the machine!

@uroni this has been going on for MONTHS ever wonder why I’m not buying more licences for more clients? I would if I could get it to WORK.

I’m also getting warnings in the event log Event 225 src Kernel-PnP urbctctl_lock.exe .. stopped removal or ejection of STORAGE\Volume\{........}#....... lots of them.

Setting CBT to disabled also has no effect.

Sorry you are having issues. To solve the problem the client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting


Sorry, been a bit busy chasing other issues for producing a debug log, however, It would appear the problem is somewhere in the logic between the settings on the server, and how Windows or the client handle loading the driver.

Reason I say that is that every configuration I tried which excludes drive M* produced this issue, the moment I gave up trying to exclude it from CBT & set volumes to “ALL” the problem disappeared.

As such, and being under some pressure to return the PC (My niece is missing her games/Facebook/etc :wink:) I’m disinclined to try excluding M again (just specifying C,D) to see if the issue comes back. I’ll just live with a volume being tracked pointlessly for the time being.

  • I don’t need or really want to track M, it stores locally produced drive images for fast local recovery and thus doesn’t need to be backed up.

Holy necro-post batman!
Anyone else suffers from this, the solution is:

Turn off UAC
Turn UAC back on.

Found by having to do so for other reasons.

Is this trick still supposed to work? I tried it and it did not work for me.

It works for me, but, only if you reboot with UAC off and CBT set to ALL.
Set to -, or a list of drives with one of the drives installed not included there’s no way whatsoever I’ve found to shut it up on a machine where it happens. On most of my client machines it doesn’t.

You can’t even set it to - after it’s gone quiet with it turned on, it comes back.

Literally the ONLY way to get that goddamn annoying pop-up notification to STFU is to install the non-cbt client. Or turn off notifications for “Settings” entirely in Windows, except you want notifications enabled for every other thing in Windows Settings & the toggle is all or nothing.

It only seems to happen on real hardware, I can’t make it occur in a VM or I’d zip the entire thing & send it for investigation.

It appears @uroni is fortunate enough not to have a test rig where it does, which is unfortunate for those of us who have actual hardware where it does.

I’m about to try an unlicensed backup with CBT turned on, then turn it off to see if it needs to actually do a backup before you can turn it off & make it go quiet. It’s peaceful rebooting with CBT enabled after the UAC & rebooting dance, but it’s not licenced for this new client & not needed, & TBH I’d rather not pay for a feature I don’t need just to make an annoyance go away.

Sorry @uroni but these things have to be tried, licence terms notwithstanding. Which didn’t help, as soon as I disabled CBT again to be in licence compliance the stupid notification is back EVERY reboot.

I’ve attached a debug log from the client which covers the period of the reboot with it happening, I see no clues in it, maybe @uroni will.

I must confess I’m SORELY tempted to set CBT on on that client just to shut the damned thing up… Licence or no licence.

I’ve also UNMARKED the solution, since it’s apparently only a workaround in some cases.

debug.log (60.5 KB)

If it’s any help whatsoever I’m seeing a lot of event 225 Source Kernel-PnP in the event log.

The application \Device\HarddiskVolume3\Program Files\UrBackup\urbackupctl.exe
with process id XXXX stopped the removal or ejection for the device 

I’m seeing the same event with “UrBackupClientBackend.exe”, “svchost.exe”, & various other .exe files cited.

Driver Verifier shows urbackupcbt.sys as loaded.