Backup Options, Groups Not Following Setting(s)

We have most clients in the default group and one client in it’s own group. The main, default group has a few optional directory locations listed in the “Default directories to backup” field using what I call the old method:


The one client in it’s own group does not have any optional locations used.

Starting earlier today, I am getting errors that this one client without optional locations is failing because the server is asking the client to look into a path that does not exist on its filesystem. The location is listed in the main group and listed as optional. I do not find the lone client also listed in the main group. The server version is 2.5.29.

I have not made any changes recently and am not sure why I would be getting this error. Server is setup to receive updates automatically, but other than that possibility, nothing else updated. I didn’t know if something else needs attention.

You can setup the group to use the main/default setting. So maybe that started working?

Maybe you can post enough information so the issue can be looked into? See this post for details Having problems with UrBackup? Please read before posting

OK - It worked without reported errors last night. This Urbackup server updated early this morning to 2.5.29. All Windows clients are working without issues.

The one I am having issues is an Ubuntu client which is also the Urbackup server. This combo is running Ubuntu 18.04.6 LTS; Kernel 4.15.0-204-generic x86_64. I didn’t catch that the Ubuntu client was still running v.2.4.11, but is now running 2.5.23 (no relief after updating client).

All client backup locations are defined within the server, not at the client level. The default group of Windows clients does include the backup location “C:\Users” which is not optional by definition. A group defined for the Ubuntu server/client has a list of directories to backup where none are optional, but does not include the C:\Users location. Ubuntu File backup status indicates “No paths to backup configured”. I tried to fix by creating a new group and placing the Ubuntu client in that group and redefining backup locations, but seemingly no help. Directories to backup are set to “Using setting configured here” Home icon.

Logs indicate this:

Errors 02/28/23 13:19 Cannot access path to backup: “C:\Users” Errorcode: 2 - No such file or directory
Errors 02/28/23 13:19 Indexing files failed, because of error
Errors 02/28/23 13:19 Constructing of filelist of “ubuserver” failed: error - index error
Errors 02/28/23 13:20 Backup had an early error. Deleting partial backup.

I will add more as I learn more.

I removed the Ubuntu client and let cleanup finish it off. I removed the group, also. I used the Add new client in Urbackup to add back the linux box. I created a new group, added the new client to that group and entered in the target directories in the “Default directories to backup” field using the settings here.

I forced a Full file backup and it still reports that the first directory from the default group cannot be found. I now have “Directories to backup are optional by default” checked on both Default and new Group File Backups page - No help.

Status page now indicates that the Ubuntu client has “No paths to backup configured”.


I’m having the same problem. After, I don’t know exactly, the last 3-4 updates of the server, the settings of the group won’t work anymore.

After playing arount again(!) with the default settings, I think I’ve found the solution:

Be sure to set the check on “Directories to backup are optional by default:” on the default File Backup section on settings.

Further attempts:

I took all the clients in the Default group and moved them to a new group with that group’s own default directories to backup. I then went back to the Default group and deleted any default directory entries.

I went back into my Ubuntu group and reentered default directories and saved. I forced a Full file backup of the Ubuntu client and the logs produce this:

Info 03/01/23 06:24 Starting unscheduled full file backup…
Errors 03/01/23 06:24 Constructing of filelist of “ubuserver” failed: no backup dirs. Please add paths to backup on the client (via tray icon) or configure default paths to backup.
Errors 03/01/23 06:24 Backup had an early error. Deleting partial backup.

Next, I entered in linux-type directories in the Default group’s default directories to backup and selected the optional check box. I now can backup most of those directories. It appears that this group (even if renamed) is only looking at the Deafult File backup locations and not it’s own settings - making sure the house icon is displayed for Use settings here. One directory would not backup and I need to look into that which may be due to a user’s permission settings.

Now the Windows clients in their own group don’t have files to backup. It’s as if the Default group is the only directory settings considered after updating the Server.

Thanks - I have already checked (and rechecked) all Groups optional by default boxes. No relief here.

OK - so, yes, I have placed all directories (Linux, Windows, etc) in the Default settings still set as optional and that seems to get me going again - I think. Testing with incremental backups is producing seemingly large backups (compared to some recently previous backups of same clients).

Same issue here, after upgrading to 2.5.29 from 2.5.28 get the error for /optional on a windows client ( only tested 1 client so far, will do some more testing, but temporarily reverted server back to 2.5.28

Hello!! my urbackup is configured for docker on 28-02-2023, an update to version 2.5.29 passed and problems started with windows clients, they stopped accepting settings from the server for groups, the settings of the “File backup” tab are not specifically applied if settings are made on the client side, then everything works (but I have a lot of users and this is not a solution) clients 2.5.23 -2.5.20. I wanted to do rolling back the server to version 2.5.28, but you do not give this opportunity, I found the current image 224.11 (but it is too old and not compatible with my database)

It looks like v.2.5.30 takes care of my problem. Thank you. I see the “Using combination of settings…” option is not showing up, so I assume this feature may have been part of the issue.

Thanks again.