Backup interval reseting, wrong format

Hello and first thanks for developers work, this is best backup solution I’ve found:-)
I have 2 problems, which last for years already. UrBackup server on Debian works well, but if I want to set interval for Disk backup in web interface, it reports “wrong format”. Integer (days) would be logical, tried also coma/decimal, but no success.
On Windows client (Win 11 Pro 64bit) I tried to set interval, but it keeps reseting. Unistall clienty app from client, delete client from server, next day reinstall, after few tries it works, or not. Problem is that after seting backup interval in client (file backup or image backup, last time file backup worked, image backup not), last time I’ve set image backup to full 720 days, incremental 430 days, but when I came to computer in the morning, it was backing up images, because times was set to 0.0843something.
It’s always challenge, using UrBackup for years and this issue always appears, after few rounds or deleting app and client it’s solved, but setting up new client is really painful.
Glad to help, waiting for inputs, ready to send logs.
Thanks in advace

Sure (debug) logs are welcome. See Having problems with UrBackup? Please read before posting for where there are/where to send.

Best would be if you manage to reproduce with a clean install and provide steps to reproduce.

Hallo, thanks for reply, I’ll try to do the logs. I always make clean install of clients. Should I make also clean install of server (don’t want to lose 1 client, which is backed up fine now, but if also server clean install is recommended, I can delete also server setting and make logs then).

With a clean install I might be able to reproduce the problem using your steps. But it really depends on how much energy you want to put into this up-front.

No problem, during weekend I’ll first make logs with just clean client install and if the problem occurs again, also with clean server install. Thanks for your support, I’ll send the client/server logs later.

New client install, image backup intervals not working. Deleted client and server, installed from scratch, performing backup now. FIle backup looks OK, image backup still running, but interval settings are not possible (wrong format and I believe after image backup it will immediately start new full and incremental image backup, like before). Setting interval from client looks fine, but after opening settings again, it’s set to 0. Setting intervals from server web interface not possible, format error occurs, do it looks like both intervals are always set to 0.
Not possible to insert screenshot. I’ll send screenshot with interval format error and server/client logs after backup is finished.

Immediately after finishing file backup and image backup server started new image backups of client. Image backup settings are set to 0 (no delay?). Sending server logs per email. In client log there is not much interesting, I’m sending just latest with unwanted starting of image backups, if needed, I can send also complete client logs.
File backup, then drive C:, D:, E:, ending succesfully with
2023-08-13 10:45:00: ClientService cmd: #IvgrQXDeS1ZyzBhYhJwoH#2LOGDATA 1691916298 0-1691909608-Starting scheduled full image backup of volume “E:”…
0-1691916298-Transferred 93.066 GB - Average speed: 119.502 MBit/s
0-1691916298-(Before compression: 103.422 GB ratio: 1.11128)
0-1691916298-Time taken for backing up client LENOVO: 1h 51m 29s
0-1691916298-Backup succeeded

Immediately after finishing image backups new backup of C: started, but this was aborted by me. This unattended backup starts after
2023-08-13 10:45:00: rc=0 hasError=true state=0

After few reinstalls (client and server from scratch), problem still appeared.
After installing Debian 12 Bookworm with kernel 6.1 everything works fine. So thread can bve closed, doesn’t work properly on old kernel, but on new kernel it performs as expected:-)

Sry, I did discover an issue in the client GUI for the image backup interval that would set it to zero. Will be fixed with the next client release.

Work-around would be to set the image backup intervals on the server.