Backup error on 1.5 - Creating directory failed

Hi everybody,

I’m experiencing a problem with Urbackup server 1.5: the server discovers the test client, but whenever a backup starts, it fails after a few seconds with the following errors:

Level   Time            Message
Errors  23.06.15 23:05  Error opening /
Errors  23.06.15 23:05  Creating directory  "/SpiderOak Hive" failed.
Errors  23.06.15 23:05  Backup failed

The SpiderOak Hive directory is the only backup source set on the test client.
I’ve tried both 1.5 and 1.4.8 clients, and got the same results.
The strange thing is that urbackup user has read/write privileges on the backup destination. This is confirmed by the fact that the SpiderOak Hive directory is created, even if the log says otherwise.

My setup is a clean install of Debian 8 in a Virtualbox VM, with just web and ssh servers installed (no X server).
I’ve also tried the same server version on a Windows XP VM, obtaining the exact same result, with just the errorcode being different (2, if I recall correctly).
I also tried different client PCs (all being phisical machines), and always obtained the same results.

I would like to contribute with testing the 1.5 version, but this major problem is preventing me from doing so…
Please tell me if I need to open a bug for this issue.
Any help would be greatly appreciated!


A quick update: I tried to install the 1.5dev server on a phisical machine with Windows 7 Professional x64, with the client on the same PC.
I always get the same error (with errorcode=2), even assigning Everybody read/write permission on the backup source and destination folder.
I may add that the exact same setup, with version 1.4.8 and the same settings, works flawlessy.
Has anybody gotten a similar error with 1.5?
@uroni, can you explain me the error codes? Have you got any suggestion?

Did you ever resolve this? I get the following sequence of errors from the client. But the same thing happens, the users folder is created on the server but the backup fails

Starting full file backup…
Indexing of “Users” done. 4126 filesystem lookups 0 db lookups and 0 db updates
ANRK-FARMOPS-15: Loading file list…
Error opening
ANRK-FARMOPS-15: Started loading files…
Creating directory “\Users” failed. (errorcode=2)
Waiting for file transfers…
Writing new file list…
Waiting for file hashing and copying threads…
Transferred 4.02593 MB - Average speed: 3.37214 MBit/s
Time taken for backing up client ANRK-FARMOPS-15: 4m 2s
Backup failed

No, sorry. I gave up after trying several different client and server OSes.
I look forward to migrate my current backup solution to Urbackup, but I’m not in a hurry since the old one works acceptably well.
Since this is still a development version, I will wait till the Beta comes out. If the problem won’t be gone, I’ll file a bug report.

EDIT: I just noticed you posted in April, saying that 1.5dev client and 1.5dev server were working well together. Have you changed something in your system, config, … since then? I’m asking because I never managed to complete a backup, not even the first after a clean install, so maybe we could troubleshoot this and find out what I did wrong.

I had it working back in April. But then i made a bunch of changes and am running it on a different server now. Thinking about it, when it was working the server was running on a computer that was running Windows 8. Maybe i will try that.


1 Like