Backing up EFI System Partition failed

Hi all

Trying to create an image backup (Windows 10 Pro N). The hard disk is a cloned one from Intel ssd to samsung ssd using Samsungs Magician software

But getting this Error

08/06/18 16:36 Backing up EFI System Partition failed. Image backup failed
08/06/18 16:36 Backup failed

My partions on the client pc is

Any thoughts on what the problem can be?


1 Like


we are having the same problem. We also used Samsung magician to clone an Intel SSD to a Samsung SSD.
The Windows event log isn’t showing anything related to this issue.

Does anyone have an idea how we can track down this issue?

Sorry you are having issues. To solve the problem the client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting


Hi uroni,

thx for your response. We enabled debug logging on the client and tried to create an image. Attached is the debug.log of the client.
debug1.log (3,3 KB)

Difficult to reproduce… Can you try if it works with this one (if not what the log shows…)

We tried again with the Beta Version, but the issue remains the same. Here is the log after starting a Backup:

2018-07-11 14:50:31: ERROR: Reading from device at position 272629760 failed. OS returned only 0 bytes +ERROR_HANDLE_EOF
2018-07-11 14:50:31: ERROR: Error while reading from shadow copy device (1).
2018-07-11 14:50:31: ERROR: Pipe broken -4

Thanks! Can you try this one?


Great, this one works! Thank you very much :slight_smile:

Thank you for this beta release. It solved my problem :+1:


I have the same problem, but the link to the beta version is broken. Can I get the version somewhere?

1 Like

I’m seeing exactly this error when backing up an Ubuntu client with client version 2.5.25 (server 2.5.32)

Backing up EFI System Partition failed. Image backup failed

Anyone else having this problem?

I’m using dattobd as snapshot mechanism and did a lot of debugging today…

I’m not really sure whats going on but I discovered two things that don’t seem right:

  1. The .datto… file in /boot/efi disappears shortly after the snapshot creation has finished. I haven’t found out what is causing this, it is not deleted within the (default) dattobd snapshot create script but it must happen later.
  2. dattobd shows me an error -27 (file too big) in /proc/datto-info shortly after the snapshop has been created. I also could not find out what operation is causing this.

Whats notable in addition to that is that I recently upgraded to ubuntu 22.04 LTS and don’t have a long experience regarding the stability of dattobd with the new kernel. So there might also be a problem in the dattobd package…